Jump to content

Recommended Posts

Using Retrospect Server 6.0.212 on a Mac Mini running OS X 10.4.2, I've been trying to back up an OS X Server 10.4.2 machine (Dual G4 MDD) running Retrospect client 6.0.110. The backup is to DVD media using the Mac Mini's SuperDrive. There are four directories I'd like to back up on the OS X Server machine (i.e., the backup client.)


When I try to run a Normal or New Media backup to backup to the DVD, the backup is large enough that it will span multiple DVDs. The first DVD fills up fine. When the first DVD is ejected and a second one requested, though, the backup will end at the point that data would begin to be written to the second DVD. The error message given in the Operation Log is "Error 515 - Piton protocol violation."


The backup script then tries to skip the directory on which it was working and continue on to the other three directories still needing to be backed up. In each case, when Retrospect tries to access the directory, an error is generated - "Error 512 - incompatible version." At that point, the script ends with an Execution Incomplete message.


If I re-run the backup script to do a Normal backup again, it will begin where it left off in the first directory, proceed through one DVD's worth of data, then throw the same error. If one DVD bridges two directories (i.e., I finally make my way through the first and can move on to the second), no "incompatible version" error is generated. But when the DVD fills up, the same error occurs when the write to the second DVD begins.


It seems as though the delay in writing caused by the need to switch the DVDs in the drive is causing a timeout in the network connection between Retrospect server and the client - the "Piton protocol violation." This "violation" then causes the attempt to backup the follow-on directories to fail with the "incompatible version" error.


Any ideas on how to solve this? Is there some mechanism I can use to see more precisely what's causing the Piton error?

Link to comment
Share on other sites

Following up on my earlier post, my retroclient.log file on the client machine (the OS X Server) is filled with these entries:


ConnWriteData: send() failed with error 32


That doesn't really help me much, but perhaps it suggests a solution to someone?

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...