Jump to content

My report: Retrospect, Pioneer DVR-A07XLB (ie, 107D) and DVD backup


Recommended Posts

I purchased a Pioneer DVR-A07XLB (OEM of 107D) in September of 2004 to archive my collection of scanned photographs. I scan 35mm film and it takes a long time to do at 4000dpi. The worst thing that could happen at this time is for my FireWire drive to die and take all of the scans with it.

 

 

 

The DVR-107D writes DVD+R at 8x. The amount of time needed to archive 100+GB of scans obviously differs greatly between 2x, 4x and 8x.

 

 

 

Unfortunately, everything that I've done since September has failed to reliably write and verify a backup set on DVD+R or even DVD-R (which is *much* slower than DVD+R; too slow!). I have tried all of the updates released in the interim including the most recent one which specifically states compatibility with the 107D. I have tried the Custom Config function on several occasions without success. When it comes down to it, Retrospect is missing something when it instructs the 107D to write/read DVD+R and DVD-R discs. That wondrous -206 error just keeps rearing its head.

 

 

 

My drive was taken back to Pioneer to be inspected and was given a clean bill of health. Every application other than Retrospect works perfectly with it, whether writing DVD+R or DVD-R (although the iLife 04 applications don't write DVD+R). In many cases, Retrospect successfully writes the discs. It simply can't recognise what it wrote. Part of the problem might be that Retrospect is using a non-standard multi-session multi-track format.

 

 

 

In any case, after making more than 100 coasters from at least 4 different brands of DVD+R 8x media, I've decided to call it a day and move on.

 

 

 

Today, I discovered that DVD+RW works extremely well and at what seems to be a very high speed (although even 'Quick' erasing can take forever). Retrospect is reporting backup speeds of around 312MB/s which is even higher than what I was getting with DVD+R! Better yet, DVD+RW by definition is rewritable so I'll be able to erase and re-use the backup discs if I wish to.

 

 

 

Question: how is it that Retrospect is writing to the DVD+RW discs faster than when writing to DVD+R discs? The 107D writes DVD+R at 8x and writes DVD+RW at 4x. Is 4x so fast that it's reached the bottle-neck of the iMac I/O system?

 

 

 

I haven't seen a single report of success writing to DVD+R on this forum. I have seen multiple reports of failure and 206 errors with DVD+R and the Pioneer 105, 106 and 107 drives. My suggestion? Try DVD+RW and see if you luck improves. Retrospect very much appears to have problems with the DVD+R protocol.

 

 

 

regards

 

Gregory

 

 

 

 

 

Mac OS X 10.3.7

 

Retrospect 6.0.204

 

Driver update 6.1.102

 

Pioneer DVR-A07XLB firmware 1.21

 

connected internally to ATAPI port of my 17" iMac 1GHz/1GB

 

 

 

Note of interest: the DVR was completely unable to write DVDs when enclosed in a MacPower Hot Buttered 1394a enclosure. It could write CDs but not DVDs. When writing DVDs, it would just spin non-stop forever until the power was turned off. This was true for all applications.

Link to comment
Share on other sites

when the backup discs were inserted for restore, Retrospect would sometimes recognise them and sometimes not. if Retrospect was able to recognise the disc, it would display the name of the disc and the backup icon in the Devices window. if Retrospect was not able to recognise the disc, it would list it as "erased". this was true even if the disc included the Retrospect text file in Session 1 Track 1 and full data in Session 1 Track 2.

 

 

 

occasionally, Retrospect would recognise the disc after removing and re-inserting it.

 

 

 

out of 50+ discs for an almost-full backup of my current scanned photograph collection, Retrospect was finally able to read all but 3 of them but it took many Restore attempts to get this far.

 

 

 

Custom Config appears to be able to write DVD+R via my Sony DVD U10W. It is unable to write DVD+R on the Pioneer when using media including eBlue 8x DVD+R, Sony 8x DVD+R, TDK 8x DVD+R and Imation 8x DVD+R. I suspect that Retrospect is still incorrectly responding to or incorrectly recognising the keys returned by the Pioneer during writing.

Link to comment
Share on other sites

I forgot to mention.

 

 

 

The DVD+R discs that Retrospect backed up to *do* have data. Dragon Burn (another third-party disc burning application) can see and extract the data from both Track 1 and Track 2 of Session 1 on each disc. Retrospect cannot see the data even though it wrote the discs.

 

 

 

Unfortunately, Dragon Burn is not compatible with the multi-track/multi-session disc format that Retrospect is using (confirmed by the Dragon Burn developers) and crashes every time I attempt to duplicate the discs.

 

 

 

My Lacie 200GB disk is failing. Hardware malfunctions are occurring and I have already lost a few iPhoto photographs on the disk because their locations are no longer accessible. Even DiskWarrior cannot find the folders which should be there.

 

 

 

It is unfortunate that HDs are so unreliable now. A few years ago, you could trust an HD to last for at least 4 years. Not so anymore. Both of my Lacie drives have failed within 2 years of purchase. In addition, many HD manufacturers only offer 1 year warranty for OEM drives instead of the 3- and 5-year warranties that were common in the 'good old days'.

 

 

 

I'm now considering a Lacie "Bigger 800" 1TB RAID 5 drive. in the long run, it might be the safest solution for my photographs and other digital media. the Bigger 800 drive is *very* reasonably priced in the USA at $1500, a lot lower than what hardware RAID 5 drives cost a couple of years ago. I'm still waiting for a quote from my friendly reseller here in Hong Kong.

Link to comment
Share on other sites

In Dantz' "Device Notes" for Pioneer/DVD RW/Macintosh devices, the Windows notes begin with:

 

In the event of a power failure or computer crash during a backup, Retrospect may be able to restore the data previously written to that disc, but the user should never try to append to this disc. In some cases, the disc may show up as "content unrecognized." If this occurs, the disc can be read in another Retrospect certified DVD-RW/+RW drive.I therefore thought to try reading my backup discs in another computer with a DVD RW device other than Pioneer.

 

 

 

Today, I visited my friendly reseller and with his permission, installed and tested my copy of Retrospect on one of their demo G5 iMacs. Retrospect (6.0.204 with driver 5.9.104) did not recognise the internal Matshita UJ-825 drive so I used Custom Config. Retrospect was able to successfully config itself for the drive with Verbatim DVD+R media, which Retrospect was unable to configure for in my iMac at home with the Pioneer DVR-A07XLB drive. I then inserted a few of my previous backup DVD+R discs (including Imation DVD+R (silver) and e-Blue TAPE 8x) and Retrospect was able to see them all. Again, Retrospect in my iMac at home with the Pioneer drive was unable to recognise these discs even though it wrote them.

 

 

 

After today's experience, I question the reliability and usability of the Pioneer drive. Even though the Matshita was not in Retrospect's drive database (note that the driver was v5.9.104 rather than the current v6.1.102), Retrospect was able to configure it to write to my DVD+R media without any problems.

 

 

 

I have ordered a new Seagate 400GB (7200 rpm, Ultra ATA, 3 year warranty optionally extendable to 5) to replace the dying Lacie Maxtor 200GB drive. Tomorrow, I will be using the demo G5 iMac to restore my backup DVD+Rs to the new drive. At the same time, I will be testing Retrospect with a new Sony DVD+-RW and NEC DVD+-RW drive with various types of CD and DVD+R/RW media to see which one is reliable. If either one proves to be reliable and fully compatible with Retrospect, I will buy it immediately.

 

 

 

sincerely,

 

Gregory

Link to comment
Share on other sites

I was at the store for at least three hours today.

 

 

 

The first thing I did was to place the new Seagate 400GB drive into my Lacie 80GB enclosure. I placed it in there rather than in the Lacie 200GB enclosure because I wanted to be able to copy data from the 200GB drive before running any Retrospect restorations to get missing data. I thought a full restoration would be faster this way.

 

 

 

Unfortunately, upon mounting the new drive, only 128GB of the 400GB were available. After searching the Apple, Lacie and Seagate web sites for solutions, reinitialising the drive a couple of times, and after calling the support lines for Seagate and Apple, I called the Lacie Australia support line and discovered the problem. The ROM in the Lacie 80GB enclosure limits access to only 128GB of any drive placed within it. The ROM in the Lacie 200GB enclosure limits access to only 250GB. In other words, I would never be able to access all 400GB of my new drive if it was mounted in one of these enclosures. If anyone plans on purchasing a Lacie drive, make sure you ask Lacie about the ROM's disk limit. You will NOT find this information anywhere on their web site.

 

 

 

After wasting more than an hour trying to solve the 128GB riddle, I turned my attention to testing the new DVD writers. My reseller had brought in the latest Sony and LG writers for me to test. Sony appeals to me more than LG so I elected to test the Sony drive first. The reseller's staff installed the drive in a PowerMac G5 for me. I installed my copy of Retrospect with the latest driver update (and uninstalled everything after my testing of course).

 

 

 

The Sony drive; a DRU-720A 16x DVD+R, 8x DVD+RW, 4x DL drive; was not recognised by Retrospect and I ran Custom Config to test it with different disc types and brands that I'd brought with me specifically to thoroughly check the drive. Retrospect and the Sony performed flawlessly with the discs including Imation SOHOT 2x-52x CD-R, Verbatim DVD+R 8x and Imation Encore 4x DVD+RW. Retrospect was also able to see and recognise the discs from the backups (e-Blue TAPE 8x and Imation silver DVD+R 8x) made but not recognised by my Pioneer DVR-A07XLB drive. I was even able to rebuild part of the backup catalog by scanning one of the backup discs; ie, Tools/Repair/Rebuild. Based on these results, I chose to buy the Sony drive.

 

 

 

Back at home, I installed the Seagate 400GB drive into a MacPower Hot Buttered enclosure, one whose FireWire bridge doesn't work well with my DVD burners. My iMac was able to see and mount the drive without any problems. I used Drive Genius to reinitialise and expand the 128GB partition to fill the whole drive. I used Disk Utility to change the partition's name since Drive Genius apparently cannot do this yet. I used Drive Genius' Duplicate function to copy the data from the 200GB drive to the 400GB drive. Even though Drive Genius reported hardware errors with the 200GB drive, the duplication worked extremely well quickly copying almost 100% of the data from the 200GB drive. This would not be possible with the Finder because it cancels the copy operation every time it encounters a hardware error.

 

 

 

With the drive working, it was time to turn my attention to the DVD writer again. I replaced the Pioneer writer in my iMac with the new Sony. It's really cramped inside the iMac (the 1GHz G4 LCD 'desk light' version) but I had no problems installing the drive (and remembering to apply heat conduction gel to the heat sinks).

 

 

 

Upon restart, I began testing Retrospect again. I had to use Custom Config again and this time configured Retrospect to support CD-R, DVD+R and DVD+RW with the Sony drive. I then restored data from both of my DVD backup sets (sets A and B) to the 400GB drive. Only 14GB of backed up data was missing from the drive and the restoration went very smoothly except for one DVD+R disc which appears to be unreadable. Retrospect reported it as "Incompatible" which is normally used to describe disc types which Retrospect has not been 'custom' configured for.

 

 

 

As I write this message, I am running the Tools/Verify function on both of my DVD backup sets. So far, everything is well although the process has only reached disc 3 of the 38-disc set at this time.

 

 

 

Overall, I am happy and relieved. I at last after 5 months of testing and torture appear to have a Retrospect DVD+R/RW solution that works. I no longer have faith in the Pioneer brand though and would advise others to thoroughly test any prospective Pioneer drive with Retrospect using the Custom Config function before purchasing the drive. Of course, in the USA, you can always return the drive if it doesn't work to your satisfaction. This is not possible in Hong Kong where once purchased, the drive is yours even if it doesn't work. Fortunately, I'm on great terms with my reseller and was able to test the drive first.

 

 

 

 

 

A few small hiccups:

 

  1. after using Custom Config with DVD+RW discs, Retrospect is unable to eject the disc. the procedure looks a little like this:
    • run Custom Config and insert DVD+RW disc (Imation Encore or Imation SOHOT)

       

      --> Process finishes.

    • Click No when asked if you wish to configure for another media type.

       

      --> The disc should eject but does not.

    • Quit Retrospect.

       

      --> The disc mounts in the Finder.

    • Eject the disc from the Finder.

       

      --> It unmounts but does not eject. One or two seconds later, it mounts again.

    • Launch Retrospect and use Tools/Configure/Devices to eject the disc.

       

      --> the disc doesn't eject.

    • Restart the Mac and hold the mouse button down during startup.

       

      --> The disc ejects. You're back in business.

    I'm not sure at this time if the bug is in Retrospect or in the Sony drive.

     

     

  2. each time you run Custom Config, all previously configured media are lost. You must configure for every possible media in one session. In my case, I also had to make sure that DVD+RW was configured last because of the eject bug. To configure my copy of Retrospect, I configured for my media in the following order: CD-R, DVD+R, DVD+RW.

     

     

  3. as the Sony loader slides out of the iMac, it is not able to fully open the drop-down door and requires manual assistance to completely extend. I'll live with it.

     

 

 

 

Anybody want a Pioneer DVD writer? ;-)

 

 

 

 

 

regards,

 

Gregory

 

 

 

 

 

Configuration:

 

iMac 17" LCD/1GHz G4/1GB

 

Mac OS X 10.3.7

 

Retropsect Desktop 6.0.204

 

Retrospect Device Driver 6.1.102

 

Sony DRU-720A via internal ATAPI interface

 

Media:

  • Imation SOHOT CD-R 52x

  • Imation SOHOT DVD+RW 4x

  • Imation Encore DVD+RW 4x

  • Imation (silver) DVD+R 8x

  • Verbatim DataLifePlus DVD+RW 4x

  • Verbatim DVD+R 8x

  • e-Blue TAPE DVD+R 8x
Link to comment
Share on other sites

  1. in the first message dated #51581 - Fri Jan 21 2005 04:11 PM, I mentioned that Retrospect with the Pioneer drive worked extremely well with DVD+RW. First, the speed should have been 312MB/min rather than 312MB/s. Secondly, I soon discovered that while Retrospect with the Pioneer drive could read/write Verbatim DVD+RW discs, they were completely unable to read/write Imation SOHOT and Encore DVD+RW discs. They were also unable to read/write Imation SOHOT CD-R 52x discs.

     

  2. While Retrospect can write to DVD+RW discs very quickly; seemingly as quickly as writing to DVD+R discs; erasing the DVD+RW discs take forever and there are no preferences to choose Quick or Full erase while backups are being made.

     

  3. in the message dated #51909 - Sat Jan 29 2005 12:38 PM, I mention interest in purchasing the soon-to-be-released Lacie 1TB Biggest F800 with RAID system. Unfortunately, it will be much more expensive to buy in Hong Kong than in the USA. See my blog for more information.
Link to comment
Share on other sites

Quote:

few small hiccups:

snip

--> the disc doesn't eject.

snip

I'm not sure at this time if the bug is in Retrospect or in the Sony drive.

 


 

Once you quit Retrospect, it's driver unloads and the Finder drive takes control of the drive again. Since the disk still won't eject, it's not a Retrospect bug. Could it be related to the need to manually "assist" the opening of the drive?

 

 

Quote:

each time you run Custom Config, all previously configured media are lost. You must configure for every possible media in one session.

Quote:

 

 

True. But you can save (rename or move) the .rdi files that contain the custom configuration information, if that helps. They're in /Library/Preferences/Retrospect/

Link to comment
Share on other sites

Dave said:

Once you quit Retrospect, it's driver unloads and the Finder drive takes control of the drive again. Since the disk still won't eject, it's not a Retrospect bug. Could it be related to the need to manually "assist" the opening of the drive?

 

This occurred whether the door was opened or closed, and also occurred on the PowerMac G5 in the store. I won't know for sure whether the bug's in Retrospect or in the drive until I perform a backup or restore using DVD+RW, and/or perform some DVD+RW operations in the Finder before ejecting the discs.

 

 

Gregory said:

each time you run Custom Config, all previously configured media are lost. You must configure for every possible media in one session.

 

Dave replied:

True. But you can save (rename or move) the .rdi files that contain the custom configuration information, if that helps. They're in /Library/Preferences/Retrospect/

 

unfortunately, you then have to remember which media types are in which rdi files, and remember to rename/replace the right rdi before any Retrospect operation. it would be preferable to be able to combine the rdi data of different Custom Config operations. the rdi data is XML but I'm not sure how it's configured. my current file which supposedly supports three media types contains the following data:

 

<key>Date</key>

<integer>-1104560368</integer>

<key>DriverFlags1</key>

<integer>1891192578</integer>

<key>DriverFlags2</key>

<integer>195</integer>

<key>DriverFlags3</key>

<integer>32899</integer>

<key>DriverFlags4</key>

<integer>0</integer>

<key>DriverFlags5</key>

<integer>0</integer>

<key>Formatter</key>

<integer>2</integer>

<key>Media</key>

<integer>152</integer>

<key>Product</key>

<string>DVD RW DRU-720A</string>

<key>RDU</key>

<string>6.1.102</string>

<key>Retrospect</key>

<string>6.0.204</string>

<key>Revision</key>

<string>JY01</string>

<key>ShowType</key>

<integer>1097019445</integer>

<key>Stamp</key>

<integer>-1104560368</integer>

<key>TestResult</key>

<integer>1</integer>

<key>Vendor</key>

<string>SONY</string>

 

is it the DriverFlags1 keys that would need to be merged?

 

regards,

Gregory

Link to comment
Share on other sites

  • 3 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...