Jump to content

automatic login on samba drives


robertfidler

Recommended Posts

I am running Retrospect 6.5.350 on a Windows XP SP2 machine and am trying to backup the XP to a Linux server running Samba 3.0.8. When I try to perform the backup manually, it works fine. When I schedule the backup to run unattended, Retrospect can't access the samba volume.

I do not have the same account on both machines, so I have filled in the automatic login fields for the backup set. This hasn't helped.

I have gone to Preferences->Security and tried to run Retrospect as the local user on the XP machine. This does no good. It won't let me enter the login information for the samba server in that window.

One more bit of info is that I have a Windows 98 machine backing up to the same samba server and everything works flawlessly (I'm actually transitioning my backup server from 98 to XP).

Any ideas?

Link to comment
Share on other sites

Hi

 

Quote:

I have gone to Preferences->Security and tried to run Retrospect as the local user on the XP machine. This does no good. It won't let me enter the login information for the samba server in that window.

 


Almost there...

 

The login information in the security preferences should be the local administrator accound for the machine running Retrospect. NOT the networked samba machine.

 

It makes no sense I know but this is required to get around some network security limitations of the Windows NT/2K/XP local system account. Windows 98 does not have this security limitation so it works with no hassle.

 

Thanks

Nate

Link to comment
Share on other sites

Nate -

Thanks for replying so quickly. I've spent a lot of time getting this to work and have made almost every mistake possible, so I thought I'd pass along what I learned.

 

You must go to Preferences->Security and enter a user of the local machine (i.e. the one running Retrospect). This user must have administrator privileges AND must have a password.

 

I didn't want to add a password to my everyday account, so I created a "Backup" account (with administrator privileges) and used TweakUI (from Microsoft) to remove the Backup user from the Welcome screen so I don't really even know it exists.

 

If you use a "dummy" account, you MUST login to this account at least once. If you don't, your backups will fail with error -1101.

 

After doing all of this, the automated backups now work flawlessly.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...