Jump to content

Retrospect does not automatically skip to blank media


Bernhard

Recommended Posts

I am about to start pulling my hair out over Retrospect.

 

We are running the 6.5.350 MSR (latest driver update 5.4, latest client update 6.5.136) in combination with a HP Surestore DAT 40x6 tape loader. For the last year we managed to keep Retrospect in check with the usual occasional but uncritical errors (unknown windows error 999, constantly ignored selectors on some server drives leading to sharing violations, etc...). Since 4 weeks I spend about 2hrs each day sorting out nightly backup problems. What happens is this:

 

We run 3 Windows servers (w2k, w2k3) with attached RAID storage (120GB). We use 3 sets that after an initial recycle backup take on incremental backups every night. Since 4 weeks two of the 3 sets ask for new media after filling up the last set member, although AUTO SKIP TO BLANK MEDIA is activated and the tape cartridge holds erased and empty tapes (every cartridge is scanned before the automated backup kicks in).

 

If Retrospect is waiting for me to select tape 2 during a recycle when I return to my office in the morning is a real pain, as the backup will then continue throughout the day significantly slowing down our production system. What is worse, is the frequent bluescreen that I get in return for letting Retrospect wait for 6hrs to continue with a new set member.

 

Of course all catalogue info is then lost and rebuilding the catalogue from the tapes has yet to work for the first time. Uninstalling both Restrospect and all clients did not change a thing, as the identical behaviour appeared after reinstallation.

 

I am not a Retrospect newby and totally aware of the automation capabilities and required settings that Retrospect offers (which I honestly like). What I do not get is how 3 identically set up backup sets behave so differently (2 not working, 1 working fine).

 

Any suggestions what to do are highly appreciated as I am rapidly getting bald (if this continues).

 

Thanks,

Bernhard

Link to comment
Share on other sites

Hi

 

To be clear: Retrospect is simply not automatically spanning tapes when the previous tape gets full. The blue screens are interesting. Retrospect won't cause that kind of thing on its own.

 

First off make sure the tape drive and media changer are disabled in the Windows device manager. Otherwise you can run into driver conflicts.

 

Also make sure you have the "automatically reuse prenamed media" preference enabled in Retrospect.

 

What types of SCSI adapters are you using? Are there any other devices on the SCSI chain?

 

Thanks

Nate

Link to comment
Share on other sites

Nate,

 

thanks for the quick reply.

 

Yes, Retrospect does not span tapes automatically when the tape gets full (during recycle and during normal backups although erased tapes are present in the cartridge).

 

On top of that Retrospect does not load the last tape member automatically when a normal backup kicks in (i.e. last night) and asks for the tape to be inserted (tape is present in the cartrigde, cartridge is scanned manually before backup starts).

 

Tape drive and media changer are disabled in the Windows device manager.

 

Other devices on the SCSI chain are one RAID controller, 2 RAID HDs and a CD drive.

SCSI adapter is an HP Ultra3.

 

Does "automatically reuse named media" make also sense for incremental backups after the recycle? It is currently disabled as I am doing normal backups at the minute and thus want to avoid erasing previous session contents on the same tape.

 

Thanks again,

Bernhard

Link to comment
Share on other sites

Hi

 

I suspect you will have much better results if you can get the tape drive on its own SCSI controller. Tape drives use Asynchronous communications where RAIDs use Sychronous. Doing both on the same controller can cause lots of trouble.

 

The automatically reuse pre-named media setting _only_ affects recycle backup operations. Your incrementals (normal) will never overwrite a tape that has not been included in a recycle backup. In other words- enable this setting.

 

Thanks

Nate

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...