Jump to content

wwwolf

Members
  • Posts

    22
  • Joined

  • Last visited

Posts posted by wwwolf

  1. Hi Everyone,

     

    I'm just putting this down in case it will help anyone in the future.  I was able to track down and solve an issue with the Retrospect Windows client that stumped support.

     

    I'm running a Retrospect Windows 10.5.0.110 and was trying to backup a Windows server with a matching client.

     

    It had been working for a year, but all of a sudden the client was refusing to backup.  I think it was stalling on either the 'Starting' step or the 'Scanning' step.  No error message, it would just hang there forever.  I had to basically reboot booth the server and client to get them talking again.

     

    I tried uninstalling the client and installing it again.  The software would install fine, but when I connected to it from the Retrospect server it would hang forever after entering the client's password.  And even if I restarted everything it would hang if I went to the 'Volumes' tab.

     

    Long story short, the problem had nothing to do with the Retrospect client itself, but with the CD-ROM of all things.  I had a disk that had been sitting in the client system untouched for a year, collecting dust.  Eventually Windows was unable to read it and would stall out.  Windows had a timer that would cause it to give up reading the disk after a couple of minutes, but Retrospect would not.  It just continued to try and read the CD-ROM over and over and over again.  Removing the CD-ROM solved the problem.

     

    If you ever get stuck like this I recommend checking all of your system volumes to make sure they're accessible, Retrospect might be stalling on one.

  2. Thanks for the suggestion, rsleegers!

     

    I think I'm on the right track, but changes in the security model (and the addition of UAC) in Windows 7 is causing me headaches.

     

    I've managed to dig up my old retroeventhandler.vbs script. I'm not sure why the example scripts don't appear to be included in Retrospect 10, but they are still called.

     

    The long story short is that I have a line that calls:

    WshShell.Run """C:\Program Files\RemoveDrive\RemoveDrive"" e:"

     

    The request executes, but RemoveDrive fails to eject the drive. So far my testing has shown that I can reproduce this error when I launch the script as a normal user, but an elevated user executes as it should. This is particularly confusing as Retrospect runs as an elevated user, so I'd expect it to launch its scripts as such.

     

     

    In any event, I've given up doing it the fancy way for the moment and just placed the call to RemoveDrive as a scheduled task. My backups are predictable enough that should work for now.

  3. Does anyone know a good way to automaticly eject a USB hard drive after the transfer to it is complete?

     

    I used to use a small commandline tool and batch script that Retrospect would run after every job. That worked fine on my old Windows XP backup box, but doesn't seem to function with my new Windows 7 setup – it never releases the drive.

     

    Anybody have a solution to this in their own setup?

    • Like 1
  4. Hi bdunagan,

     

    That's the exact page that got me thinking.

     

    It tells me how much Retrospect will improve (under ideal conditions), but I'm more interested in the technical side of it. I'm curious what changes were made under-the-hood to achieve these large improvements and if there might be any downsides to them.

     

    I don't expect Retrospect to divulge all it's secrets, but it would be nice to know a bit more so I can make the best use of the changes! :-)

     

     

    I also checked the release notes, but they didn't offer any further insight.

  5. I'm using the Mac client 11.5.2.104, and Retrospect Multi-Server on Windows 9.5.3.103

     

    The Mac is running OSX 10.10 Yosemite.

     

    That's awsome if it works for you.  I'm not sure exactly why my Mac client wouldn't touch those files.  The only other two factors I can think of are that I'm backing up a whole external hard drive, and the trouble folders were in the root of the drive.

  6. Just a heads up to anyone this may be of use to, I recently resolved a -516 client error on a Mac. The error would occur on the scan phase.

     

    Long story short, it looks like the Retrospect client has issues backing up files and folders with names containing a slash character '/'. I'm guessing this is because that character is also used by the OS to indicate folders/sub-folders. The Mac had no difficulty using the characters in names, but it caused the retrospect client to fail.

     

    Solution was to rename the files and folders to no longer contain that character.

  7. Hi Lennart,

    Sorry for the confusion. The clients are fine, it's the server that I had to migrate away from.

     

    You may be right about the Windows version. I'm moving the Retrospect server software from a Windows Server 2003 system to a Vista labtop.

     

    I've found mention to O/S migration problems here: http://forums.retrospect.com/index.php?/topic/29187-weird-matching-problem/

     

    As I have a lot of data (it would take over 24h to back it up again from scratch) it would make my life a lot easier if I could pick up from where I left off.

     

    I tried a catalog update with no luck. Next I might try a whole cataloge rebuild on the new server.

     

    Thanks.

  8. Hello all,

    I'm having an oddity with Retrospect 7.6.123 refusing to properly match files after I've moved the backup software to another computer.

     

    We had a system running our backups for years with no problems, but it's starting to develop hardware issues so I took Retrospect off it and moved it to another computer. Now when I want to run a backup of a networked client it tells me that 99% of my files are new and have to recopied.

     

    I'm at a little bit of a loss here as I don't want to use up all my backup space with a completly redundent copy of all my files.

     

    I've check my Options -> Execution -> Matching, and 'Match Source Volumes to Cataloge File' is on, 'Don't Add Duplicates to Backup Set' is on, and 'Match Only Files in Same Location' is off.

     

    Thanks.

  9. I'm trying to create a set of selectors for a multi-system backup job. On each of the systems I'd like to have different files included / excluded. I'm assuming that for all the remote systems I can refer to them by client name, but I'm stumped on how I can refer to the local system. So far I've tried 'Client name matches nothing', and it excludes all the systems.

    Any ideas would be greatly appreciated.

  10. Mayoff,

    Thanks, that sounds likely. Is there anywhere I can look for a list of things that are / are not effected by a full dist restore?

    While I understand that Retrospect is not a disk imaging tool, I would like to use it to roll back system. As a result it would be good to know what data is being left around before putting the system back out as 'fresh'.

     

    Thanks

  11. I've been running some more restores, and I've found that if I create test files and folders in the root of c: (the drive to be restored) and under a folder (this case 'documents and settings') the test data in the root of the drive is removed correctly, but the the test data under 'documents and settings' is left alone...

     

    I also ran a restore on another client system, same results.

     

    Any other suggestions? This one is confusing me.

  12. Here is a question for anyone familiar with it.

     

    I took a full backup of a Windows client system and am now trying to do a 'Rollback Everything to be exactly as it was' with Retrospect.

     

    The process completes correctly, and the system is usable, but I've noticed that it leaves files on the hard drive that were created after the backup was done.

     

    For example:

    1) Create a backup

    2) Create file c:\example.txt

    3) Run Rollback Everything

     

    The file c:\example.txt is still on the drive. It looks like Retrospect just restores everything in the backup (Including system state and registry) but leaves files it doesn't recognize alone.

     

    Anyone know why this is happening or how I can get Retrospect to give me a full system rollback (without a format that is...)

     

    Thanks.

  13. One feature I would love to see in a future version of Retrospect is for the client to be able to run on a different port.

     

    We have a small remote site with three computers, the only was I can back them up is with a site-to-site VPN. If there were a way to set the port number I could just enter each one in the router and have it forward to the correct client (Less work).

     

    This would work great with the existing 'Encrypt connection' option.

  14. I'm trying to backup the entire c: drive of a Windows 2003 system. For about the last year it's been working great, I have a Retrospect client installed and my Multi-server edition backs it up every night over the network.

     

    A few weeks ago I started getting error messages, can't think of anything that's changed – rebooting the server seemed to help at first, but isn't much of a solution.

     

    I've also tried reinstalling the client with no success.

     

    Errors:

    Can't back up Removable Storage Manager, error -517 (backup client is busy)

    Can't back up COM+ Class Registration database, error -517 (backup client is busy)

    Can't back up IIS Metabase, error -1017 (insufficient permissions)

    Can't back up WMI Repository, error -517 (backup client is busy)

    Can't back up registry, error -517 (backup client is busy)

     

    The system is available on the network, and all other operations (backup or not) are working fine and it's not under any stress as the backups occur at night.

     

    Server: Retrospect 7.5.11.100 Multi-Server Edition

    Client: Retrospect Client 7.5.116

    Both are Windows 2003 systems with 2 Ghz Processes and 2 Gb or RAM

     

    If anyone has some suggestions that would be a great help.

  15. Thanks for the heads-up Foster,

    I can deal with the errors for the most part, I’ll have to have another look at the addons.

     

    I’m a little concerned for the second (non-local) server, as the error list includes:

    System32/config/SAM

    System32/config/SAM.LOG

    System32/config/SECURITY

    System32/config/SECURITY.LOG

    System32/config/SOFTWARE

    System32/config/SYSTEM

    System32/config/software.LOG

    System32/config/system.LOG

    The local server doesn’t seem to have problems with these files.

     

    Unless I’m mistaken these SAM and (I’m assuming) the registry are rather critical for the restoration of the server. Any idea if there is a way to grab this from a remote system? I’m currently using the c: share, would the Retrospect client help?

  16. Hello, I just upgraded to Retrospect 7.5 Multi Server edition, and am currently backing up the c: of two servers (among other sources). I’ve noticed that I’m getting a fair number of ‘error –1020 (sharing violation)’ with the drives, mostly regarding our anti-virus (F-Secure), SQL Server and a few in Windows (Temp files, NTUSERDAT, etc.)

     

    Could anyone tell me if this is something I should be concerned about, or just life as normal? (or I need to buy the open file addon)

    I’m also concerned in that I’m planning to purchase the disaster recovery addon, and I want to make sure that this won’t mess up my ability to recover.

     

    Additional Information: One drive is a local c: with a domain controller (26 errors, 6 warnings), and the other is a c$ share with an SQL server (50 errors, 1 warning), both Windows Server 2003 SP1 fully patched with Retrospect 7.5.285

     

    Thanks

  17. Hello All,

    I’m I new user to Retrospect 7.0 Single Server Edition (Have some experience with an older version). I have a system up and running that backups to a removable USB hard drive, I’d like to know if anyone here has found a way to eject/unmount USB drives on Windows 2000 automatically after the backup has completed?

     

    I’ve found a program called ‘unmount’ that can do what I need, but I have to find a way to trigger the .bat file when the backup finishes.

     

    Thanks for any help you can provide.

×
×
  • Create New...