Jump to content
Sign in to follow this  

Can't restore Red Hat 7.3 Linux Server!

Recommended Posts

OK, there's got to be something simple that I'm missing. I NEED HELP DESPERATELY.


I have a Linux Red Hat 7.3 running kernel 2.4.x. GRUB is the boot loader. It has 3 data partitions- /, /usr, /var, which are set up on Linux RAID partitions (md0, md1 and md2 respectively). Swap is not on RAID, it uses an extra partition I created on each of the 2 drives.


I backed it up fine. Then I rebuilt it, being careful that the partitions laid out the same, and that the boot loader was being installed on the same partition- md0- as before. When all was ready, I set about doing a restore- to verify and document the procedure. Well, I have not succeeded yet.


I do a restore entire volume, one for each partition. I did not back up or restore /dev/shm. I reboot, and Linux stops at



It never makes it to the splash screen. I guess it can't find the boot loader? What gives? What am I doing wrong? This has happened all 5 times I've tried and I am getting VERY frustrated. I can't believe Retrospect is the problem...



Share this post

Link to post
Share on other sites



I suspect grub is confused and is not aware of the restored files.

Try this:


Boot from your install CD and hit CTRL X to get a terminal prompt. Then type:

linux initrd= root=/dev/hdxx

(for the last bit enter the root partition of your system)


Then run:

grub -install


That should update the boot info in Grub so it knows how to boot up your restored system.




Share this post

Link to post
Share on other sites

Thanks for your reply. I worked with Dantz's Linux guy and we found a solution. He said he hoped to publish something in the knowledge base about Linux restores- a darned good idea, I'd say.


For posterity's sake and for the sake of others who may come across the same problem, here is the solution. This is done AFTER the restore but BEFORE rebooting:


1. Make sure that fstab and grub.conf point to the correct mount points and partitions respectively for the current installation. If the mount points in fstab are symbolic (i.e. /usr is on partition "/usr") then you don't have to worry about it.

2. Run grub and type the following:

grub> root (hd0,0)

grub> setup (hd0)


Now you can safely reboot.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this