Jump to content
Sign in to follow this  
chrislaf

Volume Restore-Retrospect fails/Carbon Copy Cloner succeeds

Recommended Posts

System configuration: Mac OS 10.2.8 running Retrospect 5.0.238 on a PowerBook G3 FireWire (Pismo).

Backup Device: 100GB 3.5 inch FireWire HDD divided into 2 partitions - one has a file backup set and the other a complete duplicate of my Pismo's HDD. Both are complete HDD backups.

 

I recently had to restore my Pismo's HDD after a HD failure. I could restore everything from the file backup set or the duplicate and boot into OS 9.2.2 but could not boot into OS 10.2.8 no matter what I tried. I even tried wiping the drive, reinstalling and updating to OS 10.2.8, and then re-installing Retrospect as suggested on the Dantz site. At this point I was able to boot my system into the clean install of OS 10.2.8 but once I ran the restore and rebooted I was back at the grey screen with the circle with the line through it. After hours and hours of frustration with Retrospect (I tried unsuccessfully restoring to a bootable OS X system 4 times each taking about 6 hours to do as I have almost 40GB of data on my HDD), I gave up and tried Carbon Copy Cloner which is donation ware. It came through with flying colours. My restore was successful and I was up and running with my OS 10.2.8 system.

 

I have been a longtime user of Retrospect (10+ years) and it has always come through for me. Now I am not sure I can trust Retrospect anymore. I need to know that the backups that I do nightly will work when I need them. Retrospect failed when I needed it most and Carbon Copy Cloner got me through my HDD failure and back up and running.

 

I would like to solve this problem but I am out of things to try. Glad I could count on Carbon Copy Cloner.

 

 

Chris

Share this post


Link to post
Share on other sites

For interest: what did you boot from to run Carbon Copy Cloner? Did your CCC restore use the Retrospect duplicate as the master? Was the original firewire Retrospect duplicate bootable? Did you get any error messages from the failed Retrospect restores?

 

I have not done a lot of whole-system restores, so this is an opinion formed on reading the Dantz documents and forums and limited personal experience. My impression is that Retrospect struggles to do a live-system restore, that is over the top of a running system. The system must be the "exact same system" as the backed up system, presumably because Retrospect can not safely replace system components which are different but are in use. This can be a major pain as it is a lot of work doing multiple updates to get everything back into the same state. I have had one live-restore work perfectly, and one live-restore choke on restoring the Retrospect client itself which I worked around with partial restores.

 

What I am not clear about is whether it is much easier to restore onto a clean drive by getting the computer accessible from another source (like booting off a firewire drive, or using Target Disk mode). The Retrospect user guide says to install the "exact same version of Mac OS X" but goes on to describe a live-restore. Retrospect 5.1 and 6 have a bootable CD to allow clean disk restores if the original backup is accessible. Perhaps someone with direct experience can confirm whether clean-disk restores work smoothly in Retrospect, and whether there are limitations in older versions (like 5.0.238)?

Share this post


Link to post
Share on other sites

Initially, I booted from the FireWire duplicate made by Retrospect and ran CCC from there trying to restore to my internal HD, but CCC ran into lots of file copying errors and I eventually aborted the restore. I then installed CCC on a separate FW disk (a disk running OS X that has all my utilities on it) and tried the clone of the FW duplicate to my internal drive. This time the clone from the FW duplicate worked without any problems and I was able to boot into my system from my internal drive after it was done.

 

I did try a live-restore (followed exactly the intructions on the Dantz site which have you install a clean system then update to the same system you are trying to restore to) but it didn't work. I got exactly the same thing - circle with a line through it on a boot attempt.

 

In my case the only way I was able to get up and running was to restore to a clean drive from a bootable FW source.

 

It is clear that my duplicate backup was bootable but Retrospect could not duplicate a bootable system to my internal drive, likewise my file backup had all my files but could not restore to a bootable system. This is a MAJOR problem for me because I need to be able to restore bootable systems from my backups. I am holding off on upgrading my Retrospect software until I figure out what's going on. Sure would be nice if someone from Dantz chimed in on this because I want to use Retrospect but unless I solve this problem I will have to use alternate backup software.

 

Chris

Share this post


Link to post
Share on other sites

Hi

 

 

 

Just to confirm:

 

You mentioned you restored both OS9 and OSX. Did you run your backups and the restore in OSX? If either the backup or the restore was performed in OS9, OSX will not boot.

 

 

 

Thanks

 

Nate

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×