Jump to content
Sign in to follow this  
Gerk

Recatalog stuck in a loop (again)

Recommended Posts

Hi Folks

 

Ran into this problem yet again ... it seems that about 3/4 times I have to recatalog a tape I run into this problem. If for any reason during a backup something fails it ends up hanging. When cancelling that particular script from the backup server, the next time I try and run a backup script with that same tape set it tells me I have to recatalog, so I do.

 

I let the recatalog run for about 6 hours (it still showed it was cataloging files) but it looked like the same ones over and over again. I finally stopped the recatalog (scheduled building wide power outage over the weekend).

 

Today when I try and use any scripts the run from this backup set I find that it's hosed once again. It tells me that tape has 600G of data (whgich considering it's a 110G SDLT is impossible). This not only causes a problem for the tape in particular, but it also renders the backup set mostly unusable due to the 100G limitation.

 

This is getting extremely frustrating here, haven't had a suggestion or resolution to date. Anyone have any ideas?

 

 

 

 

Share this post


Link to post
Share on other sites

I can verify this. If a backup to our SDLT tape hangs, it gets stuck in a loop during recatalog until the catalog overflows the free space on the hard drive. Retrospect 5.1 (177 version), Quantum SDLT 320, OS 9.1, ASIP 6.3.

Share this post


Link to post
Share on other sites

Hi

 

Do you have the same kind of trouble if you disable ASIP? Carbon apps like Retrospect don't get along with ASIP very well.

 

Nate

Share this post


Link to post
Share on other sites

This has just happened to me again!

 

For indeterminate reasons, tape drive crashed during archive. When I tried to rebuild the catalog, it becomes stuck in some incredible loop where it keeps running long after it should have gotten all content on tape (approx. 150 gb of content, storage set that I rebuilt from scratch for second attempt now claiming approx 350gb in archive). This is with a Quantum SDLT 320 drive.

 

Are you guys going to look into this at all? I can send you logs if you want. (Basically, a very very long list of Tape Inconsistency errors.) This is one of those really serious errors, because when it tries to rebuild the catalog, it becomes fairly difficult to know what is actually in it when you see 3 or 4 copies of the same file?

 

Failing a fixed driver, is there a way to force a catalog to rebuild only to a certain point on the tape, or a certain date, or a certain block?

 

Thanks in advance,

Eric.

Share this post


Link to post
Share on other sites

The same loop is happening when I try to restore a project that I backed up to a DVD+R DL. I let it rebuild over the weekend and ended with 1.3 T of rebuilt catalog. I have Mac Retrospect 6.

 

The log said "Backup set format inconsistency (4 at 8951808)" whenever the DVD+R DL would get stuck in the loop and seem to re-catalog the files that were already cataloged.

 

What can I do to fix this? Any help would be appreciated!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×