Jump to content
Sign in to follow this  
Xathros

Linux Client Max Directory Depth ?

Recommended Posts

We have just set up a new Linux Mandrake 9.1 server and are trying to backup our files using retrospect 5.1 on a MAC 9.1 Backup machine connecting to a Retrospect Linux client.

 

On many occasions, a backup will faile with error code -24261 (mapid database corrupt)

 

This appears to happen with the directory depth is 10 or more levels deep.

 

Is there anyway to increase this limit ?

 

TIA

 

-BillO

 

Share this post


Link to post
Share on other sites

Hi

 

Mandrake isn't supported by Dantz so there are not guarantees it will work.

I would try bumping up the application memory on the mac and turning off virutual memory.

 

Nate

Share this post


Link to post
Share on other sites

Hmmm. As I understand, MDK is Redhat with some extras added on. And Retrospect does work with this one exception. All is fine until we exceed level 10 in the directory nesting structure. If I mount the volume on the MAC desktop and run the backup from that mounted volume, there are no problems but the backup is slower than death over Appletalk. The limit seems to be within the Retrospect Linux client and not with Linux itself as I can create very deep structures on the Linux volume without any trouble. I can access those structures from the MAC worstations and PC based workstations without any problems. I will increase the Mem allocated to Retrospect to see if that helps any. We do not use VM on the MAC's.

 

 

 

Thanks for any insight.

 

 

 

-Bill

 

 

Share this post


Link to post
Share on other sites

I have upped the allocated memory from 3.8mb to 20mb and the problem still exists. Are there any configuration settings for the client on the Linux end ?

 

-Bill

Share this post


Link to post
Share on other sites

UPDATE:

 

Your solution of upping the meory seems to have solved the problem. Oddly, the change didn't work until the OS9 machine was restarted. I guess I should have tried that first.

 

Anyway - thanks for the help.

 

-Bill

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×