Jump to content
Sign in to follow this  
kf4pfw

Using a client with Solaris 2.6

Recommended Posts

We recently purchased Retrospect and the associated Disaster Recovery and Open File options. So far, we have been quite pleased with the software and the support we have received has been fairly good. I called in yesterday concerning using the Solaris Client on two of our legacy Sun boxes, spoke with Mike in support and he quickly handed me off to someone who knew Solaris .

 

The Solaris tech that I spoke with worked with me until he realized that I was using Solaris 2.6 which is when he stated that Dantz only supported Solaris 8. At that point, the conversation was terminated.

 

#1, this email is NOT a complaint. I found a workaround and thought that perhaps you'd like to post it on your website for others who could quite possibly be in the same predicament.

#2, this email is also a request for an enhancement for those of us using older legacy systems.

 

While researching my problem I "discovered" what appeared to be a method of getting things working. I tried it and viola! We are now backing up our boxes.

 

When I installed the client per the knowledge base article ID 27774, I received error messages similar to the following:

 

[root@sparky rc3.d]$ ./S99retroclient start

ld.so.1: /usr/local/dantz/client/retroclient: fatal: libpthread.so.1: version `SUNW_1.2' not found (required by file /usr/local/dantz/client/retroclient)

./S99retroclient: line 34: 1481 Killed $CLIENTDIR/retroclient -daemon

 

Evidently, the libpthread.so.1 library is from Solaris 8 and is NOT backwards compatible. A search of appropriate solaris sites on the internet lead me to the environmental variable LD_NOVERSION. By setting it to "yes retroclient", I was able to get everything working. I edited the S99retroclient script in /etc/rc3.d to reflect this. My changed startup script is below:

 

#!/usr/local/bin/bash

# Retrospect Client rcl script

#

# Contact Information

#

# Dantz Development Corporation

# 4 Orinda Way, Building C

# Orinda, CA 94563

# 800.225.4880 or 925.253.3000

# customer_service@dantz.com

#

# Copyright 2000-2002 Dantz Development Corporation

#

#

# Place this script along with retroclient, and

# retrocpl in the directory specified by CLIENTDIR.

#

CLIENTDIR=/usr/local/dantz/client

 

case $1 in

start)

export LD_NOVERSION="yes retroclient"

$CLIENTDIR/retroclient -daemon

;;

stop)

$CLIENTDIR/retrocpl -stop

;;

status)

$CLIENTDIR/retrocpl

;;

*)

echo "Usage: $0 {start|stop|status}"

;;

esac

exit 0

 

It appears that the machine that the client software was compiled on had the Sun glibc library installed (SUNW_1.2) which hard codes the sun version of the library into the resulting binaries. As an enhancement, would Dantz either complie the client on an older version of Solaris (2.5) *or* make the client software source code available for compilation by the user? If I have the source, I could compile on the machine therefor ensuring that it is 100% compatible.

 

I'd appreciate your answer.

 

Thanks!

 

Mike

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×