Jump to content
Sign in to follow this  
Ericfoos

Linux client restore

Recommended Posts

I'm running Multi-server 6.0 on Windows XP Pro backing up to USB drives.

When trying to restore files from a linux client, it hangs just after the scanning stage.

There are approximately 300,000 files in the snapshot. After scanning it just sits there with an hourglass. I rebuilt the catalog and that hasn't helped. Process watcher shows retrospect pegging the CPU but there is no disk activity. How long should it take to give me a list of files to choose?

Share this post


Link to post
Share on other sites

It finally failed with a elem.cpp-861 error. I had seen this error before and was told the following

 

"elem.cpp-861 - Retrospect 6.0/6.5 for Windows users may experience this assert when doing an Immediate>Restore>Search if the backup set contains linux files. Try doing a restore via the Snapshot to avoid this problem.

Dantz is investigating the cause and hopes to resolve the problem with our next release."

 

Has this cause been found and does 6.5 resolve it?

Share this post


Link to post
Share on other sites

No, as the article states, the problem is resident in 6.0 and 6.5. We are still working towards a solution. Thanks for your continued patience.

Share this post


Link to post
Share on other sites

Hi

 

Maybe you can get around this if you do a restore without a snapshot. Can you try a "search for files" restore?

 

How about doing a backup set transfer operation using selection criteria to only transfer the files you want to restore? The smaller backup set with just the files you want may get around the error.

 

Nate

Share this post


Link to post
Share on other sites

So what is the recommendation? Don't use the Linux client? Does having all linux clients back up to their own backup set resolve the problem? If I cannot restore, backing up is pointless. Red Hat Linux is listed as a supported OS. Not being able to restore doesn't sound "supported".

Share this post


Link to post
Share on other sites

Hi

 

 

 

Agreed this is no good - there has to be a workaround somewhere...

 

Try using a clean set of preference files with Retrospect and see if it helps. Just move your 2 existing files to another folder on your hard disk. The config files are :

 

Documents and Settings/all users/application data (hidden)/Retrospect/Config65.dat and Config65.bak

 

Also make sure you reboot the machine before you try again.

 

 

 

Were you able to transfer the files to another backup set or did that fail too?

 

Have you tried rebuilding the catalog for this set?

 

 

 

Ah-one more thing: turn off the XP system restore feature on your USB hard drives - that can peg your processor for sure.

 

 

 

Nate

 

 

 

 

Share this post


Link to post
Share on other sites

I learned the system restore on the external drives early on smile.gif

I managed to get the files off of the backup set by doing a entire volume restore. It took a long time but finally worked through it. The bad thing is that the restored files filenames were munged regardless of where I restored them to(windows or Linux). The files all ended with a "." that retrospect translated to ~hj where hj is random chars from file to file when viewed from windows/mac. And it put a "?" in place of the "." when viewed from a terminal session on a linux machine.

Share this post


Link to post
Share on other sites

Hi

 

I'm glad you got your data but the filename thing is worrysome. If you try another test backup to another backup set can you restore those files or is it the same thing all over again? I want to try and rule out the "bad backup set" theory.

 

Thanks

 

Nate

Share this post


Link to post
Share on other sites

Luckily we finally got a tape library so I plan on doing a test restore this weekend to see how that works. I'll let you know my results.

Share this post


Link to post
Share on other sites

Unix files don't restore very well to the local Windows desktop. If restored through the Unix/Linux client, the file translation works correctly. D'oh!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×