Jump to content
Sign in to follow this  
Guest

Retrospect stops working when firewall is enabled

Recommended Posts

Guest

Hello all,

 

I've tried many different possible workarounds for this issue, but every single one has failed.

Thusly I'm giving this forum a try - before contacting Dantz's support.

 

Mac OS X Server version: 10.2.5

Retrospect Workgroup version: 5.0.238

 

The backup sets are working fine when OS X's built-in firewall is disabled. However, as soon as I enable the firewall, Retrospect fails to backup to my local ftp server. Naturally, the necessary port(s) are allowed/open, the filters are applied to the UDP ports as well. Check this out, opening up all the ports still doesn't do it! Bug?

 

I know Retrospect uses tcp 497 and udp 497 for traffic.

 

I've tried with several ftp servers as well, on different platforms.

 

No matter the settings, no matter what I do, the ftp connection times out. Disabling the firewall immediately solves the problem and the ftp backup works fine.

 

I've even gone as far as downgrading OS X Server to 10.2.4 and 10.2.3. Still doesn't work.

 

Can anyone shed some light on this?

 

Thanks in advance.

 

Sincerely yours

 

Jon Adolfsson

jon@mac.se

 

Share this post


Link to post
Share on other sites

Quote:

The backup sets are working fine when OS X's built-in firewall is disabled. However, as soon as I enable the firewall, Retrospect fails to backup to my local ftp server. Naturally, the necessary port(s) are allowed/open, the filters are applied to the UDP ports as well. Check this out, opening up all the ports still doesn't do it! Bug?

 

I know Retrospect uses tcp 497 and udp 497 for traffic.

 

 


 

Retrospect uses those ports for Retrospect client-server communication, but for an internet (ftp) backup set I expect that the ftp ports are used.

 

In theory a passive ftp connection would go through the firewall ok, but it looks like Retrospect uses an active ftp connection. I think this means your computer has to accept incoming ftp connections (which are initiated by the remote host in response to connections from your computer). With the Apple firewall, try turning on the ftp server to get the ports open. Help Viewer has this to say about "Using a firewall to protect your computer":

Quote:

You can't edit the ports used by built-in services. They are enabled and disabled automatically when you turn the corresponding service on or off in the Services tab.

 


Share this post


Link to post
Share on other sites

John is correct - Retrospect will only write to an FTP site in Active mode - we can't transmit in Passive mode.

Share this post


Link to post
Share on other sites

Make sure your Firewall is configured to allow FTP:

 

Go to System Preferences > Sharing

Make sure FTP Access is checked on both the Services tab and the Firewall tab

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×