Jump to content
Sign in to follow this  
emulator

Code 7358 - Windows Update encountered an unknown error

Recommended Posts

I just upgraded our test sytem to 7.7.325. We may be looking at a problem with Server 2008 restores. The good news is that there are no errors in the restore log. However, when rebooting the restored (live restore) Server 2008x64/SQL Server 2005-SP3, Windows Update claims that there was an update pending (an update that had already been installed prior to the backup):

 

http://support.microsoft.com/kb/970892

 

I ran the client's built-in Windows Update, and the update failed to install. I rebooted the client and tried the install once again with the same result. The error is:

 

"Code 7358 - Windows Update encountered an unknown error"

 

Any ideas on this? SQL Server appears to be working correctly, but I really don't want to find out that there are issues in a "crunch situation".

Edited by Guest

Share this post


Link to post
Share on other sites

Thinking that this problem may exist in 7.6 (and I just missed it in my testing), I did a test restore under 7.6. The test restore was perfect, with Windows 2008 telling me that it did not require any updates.

 

So it does appear that, for whatever reason, the security update for SQL Server 2005/SP3 that *was* installed on the test machine before the 7.7 backup does *not* get restored during the 7.7 restore. And to make matters worse, this update *cannot* be reinstalled after the restore.

 

This makes me wonder what else isn't being restored correctly (and why 7.6 has no problems restoring this test system).

 

So, ONCE AGAIN, I will NOT be going to 7.7. This update was just EVIL!!

Share this post


Link to post
Share on other sites

hmm interesting one. Was the Windows machine rebooted after the update? If WU completes the install on reboot, I guess the server may be in a strange state during a backup.

 

I seem to recall once using a command to rebuild the update database to clear a simular issue (i.e. update always failing)

 

Dunno if this helps?

 

A history of all the updates that are installed is kept in a database file. If for whatever reason this database is corrupted or mismatches the actual situation you can have it rebuild.

 

1. Click on Start

2. Click on RUN (Guess what yoy have to do if you don't have a RUN option?)

3. Type CMD and hit OK

4. In the MS-Dos screen that appears type the following commands:

net stop wuauserv [Enter]

This will stop the "Automatic Updates" service that is using the database.

5. Now lets switch to the Windows directory - Type

CD \Windows [Enter]

(If you get "The system cannot find the path specified" then Windows is installed in another folder. Type SET [Enter] and look at the option "windir")

6. Type:

Rename SoftwareDistribution SoftwareDistribution_OLD

which will rename the folder containing the database.

7. Type:

net start wuauserv [Enter]

8. Now try Windows Update again. This may take a while (With the green bar going back and forth) because the database has to be rebuild.

 

 

Rich

Edited by Guest

Share this post


Link to post
Share on other sites

Hi Rich...

 

Thanks for the suggestion. Unfortunately, this didn't solve the problem.

 

I reported to EMC tech support, and they believe that this is a bug.

Share this post


Link to post
Share on other sites

There's another issue with 7.7: it does not restore Server 2008 cluster information correctly. I know that the documentation states that Retro does not restore a clustered state, and that the cluster will have to be recreated after the restore, but 7.6 actually DID restore the entire clustered state without issue. I found a way of getting 7.7 to restore the clustered state in a round about way, however, by using the Retrospect RegCopy program (included with every install of the Retrospect client. The procedures are as follows:

 

1. Use the RegCopy program to back up the client’s registry.

2. Back up the client with Retrospect.

3. Wipe the client clean, reinstall Windows Server 2008, reapply all Windows updates, and reinstall the

Retrospect Client.

4. Restore the client.

5. Use RegCopy to restore the client’s registry from the data in step 1.

6. Reboot the client.

 

I've reported this to EMC.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×