Jump to content
Sign in to follow this  
dangermouse

mailbox wont restore, Exchange Mailboxes in use by another program

Recommended Posts

Hi All,

 

We're trying to recover just the Inbox of a single mailbox. We get the error 'Exchange Mailboxes on msexchange is in use by another operation. Wait for it to be available?'

 

Retrospect is not doing anything else.

 

We have set up a Recovery Storage Group, with restore allowed. Restore is not allowed to the actual Mailstore.

 

Any idea where we've gone wrong? Thanks.

Share this post


Link to post
Share on other sites

Have you tried doing a database restore to the recovery storage group?

 

What if you try to restore that inbox to a different mailbox? What happens?

Share this post


Link to post
Share on other sites

Didn't try a database restore, no. Didn't seem worth the risk! I guess I wasn't confident enough the restore would go to the recovery group.

 

I did try restoring to a couple of other mailboxes, same result.

Share this post


Link to post
Share on other sites

Have you tried rebooting the exchange server to see if this "busy" process frees itself?

 

Any errors in the Windows Event Logs?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×