Jump to content
johnwmreed

Error messages when load drivers for emergency recovery

Recommended Posts

I have been testing my Retrospect 7.7 Emergency Recovery CD.

 

Before booting the recovery disk I have gone to my computer's Device Manager -> network adapters and determined what I believe to be the *.inf file for the adapter and put it on an USB flash drive.

 

After I boot the Recovery CD I click on "Load Drivers for Network or Storage Adapters"

 

I point to the *.inf file and load it. But I get the following list of error messages:

 

Drvload: Unable to load G:\Disaster (error 0x800700002)

Drvload: Unable to load Recoverly\Retrospect\Driver (error 0x800700002)

Drvload: Unable to load inf (error 0x800700002)

Drvload: Unable to load file(error 0x800700002)

Drvload: Unable to load for (error 0x800700002)

Drvload: Unable to load HP (error 0x800700002)

Drvload: Unable to load Computer\yk60x86.inf (error 0x800700002)

 

What do these messages mean?

Do I have the wrong *.inf file?

:question:

 

Share this post


Link to post
Share on other sites

0x800700002 means "Cannot find the file specified".

 

I guess the cause is either your .inf file is wrong or some required driver files are missing.

 

In addition, make sure all required driver files (.inf, .sys, .cat ...) are placed under the same folder.

 

 

 

Share this post


Link to post
Share on other sites

Well, this is my problem -

 

When I "Load Drivers for Network or Storage Adapters"

if I drill down to the folder that contains the *.inf file on my C:\ drive (i.e., C:\Windows\System32\DriverStore\FileRepository\yk60x86xxxxxx\yk60x86.inf) the driver loads just fine.

 

But if I copy all the files (i.e., inf, cat, sys, etc.) to a directory on my flash drive, then run the Emergency Recover CD and point to the yk60x86.inf file I get the page of error messages.

 

This is a Catch 22. If I am running the Emergency Recover CD for real it is because my hard drive got corrupted. Hence I can't load the network device drivers and I can't restore my hard drive files (Retrospect backup is on a Network drive). The other side of the Catch 22 argument is obvious.

 

There must be some way of putting the network device driver files on a flash drive.

 

Are there more driver files hiding on my computer that I need to include? :confused2:

Share this post


Link to post
Share on other sites

Understood.

I think only YK60X86.inf, YK60X86.sys and YK60X86.CAT are required.

 

Please copy only these 3 files onto an folder of a flash drive and try again.

 

If still no success, please try to download the driver installation package somewhere and extract (don't install it, just extract) these 3 files onto the flash drive and try again.

 

Good luck, John and let us know the result.

Share this post


Link to post
Share on other sites

I tried both your suggestions and neither worked.

 

So I decided to burn the inf directory onto a CD and load from that - It worked!

 

So I am wondering now:

 

Is there something wrong with my flash drive (I only have one and it has been working great for other things)?

 

or is there the possibility that flash drives don't work for this operation? :oneeye:

Share this post


Link to post
Share on other sites

This is turning out to be more complicated:

 

As long as I only put one inf file directory on a CD I can load the network drivers in the retrospect Emergency Recovery CD process. I have two computers so I thought I would just put them both driver files on a single CD (in separate directories). This doesn't work for either computer - the inf drivers will not load.

 

Also, I am getting inconsistent results mapping the network drive. Using exactly the same UNC on both computers one computer will sometimes connect to my network drive, but the other computer will never connect.

 

Why am I spending all this time trying to get this to work?

 

It is because I am going to walk away from this and in 6 months one of my computers may crash and I will need to run the Retrospect Emergency Recovery CD to restore my system. I want it to work. My experience with Retrospect recovery in the past has been mixed. One time I was successful and an other I failed to restore my system (I did get my data files).

Share this post


Link to post
Share on other sites

Hi John,

 

The problem you met is a little weird. I don’t know why so far, but there is a work around here,

After completely booted from Emergency Recovery CD (the wizard UI shows up), the Emergency Recovery CD can be removed from your CD-Rom. That means you can insert another CD which contains driver files for your second computer.

I know this is an ugly workaround, but I believe it should work.

 

In addition, for mapping the UNC path, make sure your network card has already been loaded successfully first. Otherwise mapping UNC path operation won’t succeed. To check if your network card is working correctly, you can perform the “Restore as clientâ€, if IP address is retrieved, that means your network card works correctly.

 

Hope this can help.

Xianfeng

 

Share this post


Link to post
Share on other sites

I do remove the Emergency Recovery CD from my drive after the wizard UI shows up. Then I place my network driver CD in the drive to install the network drivers. At this point I am now successful with both of my computers - "Load drivers for network or storage adapters" works.

 

"Map network drive" works fairly well for my older Vista 32 home premium computer. Retrospect restore can find the catalog files and I am reasonably confident that I could complete a full restore.

 

"Map network drive" does not work for my brand new Windows 7 64 bit home premium computer. I execute this step AFTER I have loaded the network drivers. I always get the error message:

 

"System error 53 has occurred

The network path was not found"

 

I use exactly the same UNC path as for the Vista computer: \\mybookworld\backup

 

Also, under normal computer operation my network works fine - no problems with either computer.

 

If I do a "Restore as a client" I do get a IP address for the server to connect to the client, but it is not the correct address.

 

I am at the point where it doesn't look like I will be able to do a full restore with the Emergency Recovery CD if my Windows 7 computer fails. I assume I can still do it the old way: Load Windows -> Load Retrospect -> Restore. But that path may also have problems connecting to my network drive where my backup files reside. :taptap:

 

 

Share this post


Link to post
Share on other sites

It has been 2 years now, and I still have not solved my problem (see initial post above).

 

Still, if I try to do a trial recovery with my Retrospect Emergency Recovery CD I can't install the NAS drivers - I get the same error messages (see initial post above).

 

What has changed is I have started independent Windows generated image backups of my two computers onto the same NAS drive. I have no problem using the Windows System Repair Discs to recover the image backups. This involves also installing the NAS drivers. It works! No problems. This says that I have the right drivers and the Windows System Repair Disc for each computer (one 32bit and the other 64bit) can recognize them and install them.

 

I am using the same driver directories on my USB drive for both image and Retrospect recoveries.

 

So why can't I do the same thing with my Retrospect Emergency Recovery CD?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×