Jump to content
Sign in to follow this  

Grooming script won't stop/quit ?

Recommended Posts

I'm relatively new to R8.


Set a grooming script but overnight it didn't find media and now I cannot get it to quit and let other scripts run.

Not sure why the other scripts would not run since they are all set to use any Activity Thread.


Tried everything I know of to stop that script:

I used the Stop and Pause, I removed the script, I tried without success to stop R Engine in Preferences. I tried to find more media for it to groom. Nothing!


Finally turned Retrospect Engine off at startup but now I don't have Retrospect at all. :-(

I haven't turned Engine on manually because I assume the problem will just continue.


I'd like to remove Grooming script... I did delete it but not sure that held.


And I'd like to proceed with my hourly, daily backups and clones.


Any suggestions appreciated.



  • Like 2

Share this post

Link to post
Share on other sites

Hopefully this post will help others with this problem.


I have run into groom scripts that won't finish and can't be stopped manually.

I'm running Retrospect 9 on Mac OS, but I expect this will apply to v8 and likely others.


Delete the .log file for your catalog. See the details below.


After the script had been running for several days with no apparent progress, I was confident that it was hung. I tried stopping it in the Retrospect UI. It popped up the 'are you sure' dialogue and I clicked stop a second time. I waited several hours and nothing changed, the script was still 'running'. I tried re-booting the system, which took a long time because it had to wait for Retrospect Engine to shut down. Once it restarted, the grooming script continued doing nothing just as before.


Next, I stopped the Retrospect Backup Engine in System Preferences. I waited several minutes until it said it was 'stopped'. I unchecked the 'Launch Retrospect Engine on system startup'. and re-booted. Then I went into Library - Application Support - Retrospect - Catalogs. In that folder I deleted the .log file for the backup set that it was trying to groom. Then I started the Retrospect Engine as well as the UI and the grooming script was gone!


I immediately started rebuilding the backup set's catalog. I assume the grooming failed because of an error in the catalog, but YMMV.


I suspect that the .log file represents the progress made by the grooming script. When Retrospect starts it sees the log file and tries to continue where it left off. By deleting the log file, Retrospect doesn't see that a groom was in progress so it doesn't try to continue doing nothing.


In general I find myself having to rebuild catalogs fairly often (several times per year). I haven't seen any recommendation or standard practice suggesting how often this should be done. Should I have a re-build script before and after each groom?


Retrospect works great until it doesn't . . .


Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this