Jump to content
Sign in to follow this  
cunderw

Excluded directories on Solaris

Recommended Posts

I set up Retrospect to backup a Solaris server once a week. On the UNIX client I added some directories in the retroclient.excludes file so they would not be backed up. I will be discussing the results of two backup sessions in a two week span. Both backups used the same backup set.

 

 

 

The first run of the backup went as expected and none of the excluded files were backed up. However, when the script ran the second week it only backed up the files that had changed since the last backup (as expected) and also included all the files that are on the exclude list. I checked the client and the exclude option is turned on. Is this a bug or is there an option that needs to be set in the application to keep the excluded data from being backed up on the second backup?

Share this post


Link to post
Share on other sites

The only option that is lost when the client stops is the IP switch. All other options (log level, proactive backup options, private files and folder, etc) will remain in force when the client is restarted.

 

 

 

You may want to check that nothing happened to the excludes file itself. It should be located at /etc/retroclient.excludes. If its name was changed or the information within it were erased that would explain the behavior you are seeing.

 

 

Share this post


Link to post
Share on other sites

i have a similar problem with my solaris 8/ultrasparc e450 machine.

 

 

 

my /etc/retroclient.excludes has the following entrys.

 

 

 

/root

 

 

 

my retrocpl.status give me the following informations.

 

 

 

/usr/local/dantz/client/retrocpl

 

Server "xxxx.xxxxx.xxx":

 

Version 6.0.143

 

back up according to normal schedule

 

currently on

 

readonly is off

 

exclude is on

 

0 connections, 0 authenticated

 

 

 

but every backup will backup the /root directory

 

have any a idea?

 

 

 

andreas

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×