Jump to content
bluffwood

Scheduled Duplicates Don't Copy Files

Recommended Posts

I am not able to get Immediate Duplicate scripts (created in Advanced Mode) to copy the selected files when they are scheduled rather than run immediately. The scripts run on schedule and complete normally, they just don't copy the files. They use the "replace corresponding files" option. If I create identical Immediate Duplicates and run them immediately, the same selected files will be copied. Is this a bug or am I missing something?

 

I'm using Retrospect Express 7.6.123 with Windows XP Home SP3.

 

Thank you for any thoughts!

 

Mark

Share this post


Link to post
Share on other sites

I just discovered that scheduling an Immediate Duplicate script in Advanced Mode apparently causes Retrospect to forget the custom file selections you made using the Files Chosen button/panel. The script reverts back to the default files identified by the choice made with the "Selecting" button/panel. In my case, I chose the "No Files" option since I only wanted to duplicate one file - the Retrospect catalog for the backup set (which I marked in the "Files Chosen" panel). Once I scheduled the script it reverted back to selecting "No Files."

 

I tested the mirror image case, using a selector that would find a number of files and then de-selecting some of those files in Files Chosen. The scheduled script duplicated all of the default files including the ones I had de-selected.

 

I am now fairly sure this is a bug. Effectively, this means scheduled duplication scripts limit the duplication choices to the pre-determined file sets defined in the "Selecting" panel. To duplicate a custom set of files you must manually create and immediately run an Immediate Duplication. This is fairly limiting. Hopefully this will be fixed.

Share this post


Link to post
Share on other sites
I just discovered that scheduling an Immediate Duplicate script in Advanced Mode apparently causes Retrospect to forget the custom file selections you made using the Files Chosen button/panel.

 

Manual file selections are for immediate operations only and are NEVER saved for scheduled operations. This is by design and is expected normal behavior.

Share this post


Link to post
Share on other sites

Thank you for the clarification. At least now I know this is not a bug. I also now understand why there is no "Files Chosen" button in the Manage Scripts window.

 

I don't care for the design choice since it prevents the scheduled duplication of a set of specific files in various directories. The only other option I can see is to define every desired directory as a subvolume and take all files contained in those subvolumes, even if you don't want/need most of the files backed up.

 

At a minimum, it would be nice if Retrospect warned you when choosing the scheduling option that manual file selections will be ignored.

 

Thanks, again.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×