Jump to content
Sign in to follow this  
tavarvel

Error 109 - Trying to restore files from old tapes

Recommended Posts

I recently had to replace my old HP SureStore DAT 24 SCSI tape drive with a new HP StorageWorks DAT 40 USB. I have not had the need to access any of the old tapes for over a year or so. Recently, after trying to restore files from an old tape, I discovered that my drive would not load any of my tapes.

 

After research, I found that the HP Storageworks DAT 40 USB was my best bet because it can read DDS2, DDS3, and DDS4 tapes. I do have 6 DDS tapes but will probably have to live without getting that data for now.

 

Here's my problem...Retrospect finds locates my specific file in my backup set and informs me of the appropriate tape that it is on. When I load the correct tape, Retrospect confirms that it is the correct tape, however, when it tries to search for the file, I eventually, after a few minutes, receive an error. Error 109 (unexpexted filemark or FTP end of file)

 

Can I still read the data from tapes written by my old SureStore DAT 24 drive with my new StorageWorks DAT 40 USB? What are my alternatives? Any help would be appreciated.

 

Here are complete configuration information:

OS 10.4.11

Retrospect version: 6.0.204

Driver Update version: 5.9.104

Share this post


Link to post
Share on other sites
Here are complete configuration information:

OS 10.4.11

Retrospect version: 6.0.204

Driver Update version: 5.9.104

Well, at minimum, you need to update your RDU. I'm surprised that such an ancient RDU (from Retrospect 5) even loads with Retrospect 6.0.

 

According to the Retrospect Supported Devices database, at least RDU 6.4.102 is required, and you don't meet that requirement:

Retrospect Supported Devices - HP StorageWorks DAT 40 USB

 

The complete history of RDU updates (with download links) is here:

Retrospect Macintosh RDU version history

 

Also, your version of Retrospect is very old, and the update to the current 6.x version (6.1.230) and the latest RDU is free:

Retrospect 6.x and 6.x RDU updates

 

However, on the subject of reading your old tapes, the path may be a bit complex.

 

There are rumors in these forums (and from EMC support) that the current version of Retrospect Mac 6.1 (6.1.230) cannot read tapes from older versions:

Retrospect 6.1.230 cannot restore older version tapes?

 

So some bug may have been introduced in Retrospect 6.1.x at some point that removed the ability to read older versions of backups. To me, that is quite serious because the whole point of a backup program is to restore older backups, but perhaps I am in the minority.

 

Now, I know that I did restore some Retrospect 2.0 DAT tapes using Retrospect 6.x, but it may have been Retrospect 6.0.x. I don't have that old DAT drive hooked up to our xServe right now, so I can't answer that question.

 

But see the above-linked thread for some suggestions. You might want to update the RDU to the last RDU version for Retrospect 6.0.x, or you might have to try Retrospect 5.1 (which is on the Retrospect 6 CD). At a minimum, you will have to recreate a new backup set catalog from scratch, because older catalogs have different format.

 

Good luck, hope this helps,

 

Russ

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×