Jump to content
Sign in to follow this  
Mayoff

Increasing Retrospect's Niceness increases responsiveness

Recommended Posts

Increasing the Nice value to improve Retrospect 8.0.608 responsiveness

 

Discussion:

 

Mac OS X allows you alter the scheduling priority of a process by adjusting its Nice value.

 

To adjust the Nice value for your copy of Retrospect 8.0.608 on an Multi-core Intel Mac, do the following:

 

1) Stop the Retrospect Engine from the System Preferences pane.

 

2) Locate: /Library/LaunchDaemons/com.retrospect.launchd.retroengine.plist

 

3) As a root user, change the Nice value in this file from the default of Zero. The number must be between -20 and 20. The lower the value the higher scheduling priority the Retrospect engine will get. -20 will tell the Mac OS X to give Retrospect engine highest scheduling priority.

 

4) Start the Retrospect Engine from system preferences pane.

 

The Nice value should only be changed if you have an Intel Mac with a multi-core processor.

 

 

Edited by Guest

Share this post


Link to post
Share on other sites

So, my backup mac is an intel "core 2 duo" mini.

 

Two questions:

 

1) Will I need to redo this after every Retrospect upgrade?

 

2) If I change this setting to -20, what immediately obvious differences should I see? Either within Retrospect or in the Finder if I was doing something else?

Share this post


Link to post
Share on other sites

We are investigating ways to automatically handle the Nice settings in future updates. We didn't want to make a last minute installer change, so we left the setting to the KB article.

 

The change will probably not "rock your world". It will allow the engine to use more CPU then it did before, hopefully giving you a little speed boost.

 

-20 is safe for most users, especially if this is dedicated for backups. If you use other CPU hogs (Fusion would be an example) then you may want to play with the value over time.

Share this post


Link to post
Share on other sites
The Nice value should only be changed if you have an Intel Mac with a multi-core processor.

Hilarious.

 

Apple shipped exactly one Core "Solo" machine, the 1.5 Ghz Core Mini (MA205LL/A), on the market for about six months in 2006.

 

Every other Retrospect compatible machine has a multi-core processor.

 

Dave

Share this post


Link to post
Share on other sites

Hi,

 

I wonder about the mentioned nice settings as the MACH kernel of all Mac OS X versions is not priority aware.

 

(control the scheduling priority value via ps -ef, it will always say 0)

 

 

with best regards

 

G. Oei

 

 

 

Share this post


Link to post
Share on other sites

That may be what ps says but setting the priority to -20 has made R8 feel normally responsive to me under 10.5.6.

 

This helps a lot!

 

**Leigh

Edited by Guest

Share this post


Link to post
Share on other sites

ps -ef doesn't tell you anything about priority. ps -axl does. It appears to me that macos is priority aware. read man setpriority. I assume process priority is different than thread priority.

 

I'm not sure I would give it a priority any higher than 46 (nice -15). Those are some important processes at 46.

Share this post


Link to post
Share on other sites

Nice -20 is dangerous. Priorities inside the OS are pretty important, and "negative" nice for user processes is restricted to root for a reason.

 

Even nice -15 is aggressive.

 

Running at nice -20 on a busy machine is likely to run into deadlocks and/or starvation under heavy load, or at seemingly random intervals. (i.e. hangs and crashes of the OS)

 

A minor gain of responsiveness at the cost of stability is a bad trade.

 

-dgl-

Share this post


Link to post
Share on other sites

Among other issues, I had a problem where the backup of one Windows 2003 server would always stop, every time, with no error message or log file. The console would lose connection, then come back with the backup stopped.

 

I increased the niceness to -15 and now it is working OK. The console is now MUCH more responsive also.

 

Retrospect 8.1, server is a XServe G5 dual 2.3GHz w/ 2GB ram running 10.4 server, console station is a PMG4 MDD dual 1.4GHz w/ 2GB ram running 10.5 client.

 

MK

Edited by Guest

Share this post


Link to post
Share on other sites

I have to retract my statement that it was working OK. The same problem with the backup quitting has cropped back up. The console still seems to work OK though.

 

MK

Share this post


Link to post
Share on other sites

I changed the nice setting to -20 and noticed no difference at all. Client backups are still unacceptably slow. It should not take days to backup 4 1 Tb hard drives over a gigabit network using a pair of 3.2 quad core Xeon CPU's with 24 Gb of RAM.

Share this post


Link to post
Share on other sites
I changed the nice setting to -20 and noticed no difference at all. Client backups are still unacceptably slow. It should not take days to backup 4 1 Tb hard drives over a gigabit network using a pair of 3.2 quad core Xeon CPU's with 24 Gb of RAM.

 

No one claimed that this would speed up backups. The claim was that it would speed up the interface, in particular the time it takes for it to respond to the user.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×