Jump to content
Sign in to follow this  
danfforemostgraphics.com

Can't see Individual Mailboxes

Recommended Posts

Hello everyone,

 

Here's my config

 

Exchange server 2007 running on

Server 2008 Enterprise 64 bit

Retrospect client 7.6.107

 

Backup Server

 

Server 2003 R2 64 bit

Retrospect App installed

This is the only app running on this box

 

When I try to "login as" under Volume database I keep getting the login window bouncing back saying "Sorry Authentication failed. Please Retry:

 

I have read over the documentation thourghly and tried all the work arounds I can find on this web site. It is installed just as outlined in the appendix B, and the server components are installed on the exchange server.

 

Someone please help : (. I don't feel I should have to pay for support when I have followed all the steps and I believe it is correct, I'd be happy to pay if someone at EMC could find that I'm doing soemthing wrong...

 

Thanks, Dan

Share this post


Link to post
Share on other sites

What are the EXACT versions of Exchange, WIndows and MAPI?

 

 

Does it matter if you use the fully qualified domain name instead of the simple domain name?

Share this post


Link to post
Share on other sites

Exchange server 2007

Update rollup 5 and 6 for Exchange Server 2007 Service pack 1

 

Running on

 

Server 2008 enterprise 64 bit Service pack 1 all update applied

 

Messaging API and Collaboration Data Objects 1.2.1

 

Microsoft Visual C++ 2005 Redistributable (x64)

 

it is configured for Outlook 2003 compatability

 

I will try the FQDN

 

It will accept the domain administrator account and it's password, but you still can't see the individual mailboxes

 

Dan

Share this post


Link to post
Share on other sites

Try to follow these steps:

 

 

 

1) Logon to Windows (win2k8 + ex2k7) with the RBU account.

 

 

 

2) Launch “MFCMapi.exe”. Click “Profile -> Show Profiles”. In the “Profiles” window, click “Actions -> Create Profile” to create a new profile.

 

 

 

3) Select the newly created profile, and click “Actions -> Add Services”, and input “MSEMS” as the service name.

 

 

4) Input the Exchange name, and the RBU account for mailbox name. Click “OK” to finish.

 

5) Close the “Profiles” window. In the main window, click “Session -> Logon with flags”. Input the profile name that just created, and input “0x00018022” as the Flags. Click “OK” to finish.

 

6) In the main window, click “MDB -> Open Other User’s Mailbox…” and choose a mailbox to view.

 

7) In the new window, click “Special Folder -> Inbox”. In the “Inbox” window, click “Actions -> Open Contents Table”.

 

 

Edited by Guest

Share this post


Link to post
Share on other sites

I have reset your forum permissions to allow you to attach files to the forum. I would love to see them and give them to engineering.

Share this post


Link to post
Share on other sites

Try Switch to full reply and click Manage Files. If you don't see the button, then try a login again.

Share this post


Link to post
Share on other sites

Is IP6 turned on for the Exchange Server (win 2008)? IP 6 doesn't work correctly with MAPI. Can you try to turn off IP 6?

Share this post


Link to post
Share on other sites

In addition to the above post, your failure when running the MS tool is a smoking gun. If that tool fails, then Retrospect will fail too. The problem you are having is at the system level and not Retrospect.

 

MAPI_E_LOGON_FAILED==0X80040111 means the you can't login to the Exchange

Server via MAPI. It may be some problem of MAPI when working in some

environments, although Outlook's MAPI works well.

 

Make sure:

 

1. RBU is a member of Domain user, domain admin, Administrator, Backup

Operator, Enterprise Admin.

 

2. Confirm you used RBU to logon to Windows server itself before running the tool.

 

3. When adding "MSEMS" service, input the correct Exchange Server name, and

input the RBU as the mailbox name.

 

 

Share this post


Link to post
Share on other sites

other users have reported the following steps help with this problem. Please let us known if it works for you

 

Test Environment:

Machine1: Win2k8 DC (domain controller) installed AD

 

Machine2: Win2k8 + Exchange 2k7 + Retrospect

 

 

 

Depending on whether RPCRroxy is on the same server as the Mailbox role, there are two cases.

 

Solution for CASE 1:

 

If you're in a multi-server scenario where the RPCProxy is not on the same server as the Mailbox, then you need to do the following:

 

 

 

Unselect IPv6 from the properties of your NIC (on the RPC-over-HTTP Proxy machine); that will force the RPC-over-HTTP Proxy to use IPv4 to talk to Exchange and everything will be fine. In most cases, this step suffices. If it does not, continue with steps 2 and 3.

 

Under the regkey HKLM\SYSTEM\CurrentControlSet\Services\Tcpip6\Parameters, add a 32 bit DWORD with the name DisabledComponents and value 0xFF

 

Reboot the machine

 

 

 

Solution for CASE 2:

 

If you're in a single-server scenario where the RPCProxy and Mailbox are on the same machine, then the above does not work since the loopback interface still uses IPv6. In this case, you need to make the following changes in the system32\drivers\etc\hosts file:

 

 

 

Comment out the line ":::1 localhost"

 

Add the following two lines:

 

 

 

 

 

My enviroment belongs to case 2, the following is my change to hosts file.

 

 

 

# Copyright © 1993-2006 Microsoft Corp.

 

#

 

# This is a sample HOSTS file used by Microsoft TCP/IP for Windows.

 

#

 

# This file contains the mappings of IP addresses to host names. Each

 

# entry should be kept on an individual line. The IP address should

 

# be placed in the first column followed by the corresponding host name.

 

# The IP address and the host name should be separated by at least one

 

# space.

 

#

 

# Additionally, comments (such as these) may be inserted on individual

 

# lines or following the machine name denoted by a '#' symbol.

 

#

 

# For example:

 

#

 

# 102.54.94.97 rhino.acme.com # source server

 

# 38.25.63.10 x.acme.com # x client host

 

 

 

127.0.0.1 localhost

 

#::1 localhost

 

 

 

10.32.100.245 win2k8-exch2k7

 

10.32.100.245 win2k8-exch2k7.win2k8sp2.com

 

 

Edited by Guest

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×