Jump to content
robvil

cannot email anymore

Recommended Posts

Hi,

 

I just noticed after migrating to windows 2008 Retrospect cannot send emails.

 

I get this during test from Retrospect:

 

email notification failed: error -541 (backup client not installed or not running)

 

 

I am able to telnet the mailserver from the retrospect from a command prompt though.

I am running ver. 7.6.123.

 

Any ideas?

 

Regards

Robert

 

Share this post


Link to post
Share on other sites

Okay found the bug.

 

I have always been using a ip address for the smtp server, but this do not work since ver. 7.6.123.

 

If using ip address in smtp server field I see:

 

+ Driver Update and Hot Fix, version 7.6.2.101

soctSetThread: socket thread now 0xcfc

smtpOpen: connecting using port 2.560

soccOpen: socket send buffer size is 65.536

soccOpen: socket recv buffer size is 65.536

soccCallback: FD_CONNECT failed, error 10061

smtpOpen: connection failed using port 2.560

smtpSend: "QUIT"

soctPreDispose: maximum queue depth was 1

soctSetThread: socket thread now 0xcfc

smtpOpen: connecting using port 2.560

soccOpen: socket send buffer size is 65.536

soccOpen: socket recv buffer size is 65.536

soccCallback: FD_CONNECT failed, error 10061

smtpOpen: connection failed using port 2.560

smtpSend: "QUIT"

 

So I changed it to a FQDN and this works. :)

 

Regards

Robert

 

Share this post


Link to post
Share on other sites

We did make a change to email notification in 7.6.123 so that users can pick the port number. Hopefully we didn't break anything along the way.

 

You should now be able to enter IP:port number

 

192.168.1.12:25

Edited by Guest

Share this post


Link to post
Share on other sites

Same problem here.. IP address with no port number specified breaks with the same error as the original poster. Looks like if you use an IP address now you *have* to specify a port number or it breaks.

 

Also, I can't remember if it did this prior to the upgrade, but when you click the send test email button after specifying an IP:port number the GUI gives you absolutely no feedback that it did anything at all. It looked busted until 5 new messages showed up in my inbox.

Share this post


Link to post
Share on other sites

Just another confirmation of what is said above.

 

1. Upgraded to 7.6.123 and email notifications stopped. A test send from the preferences screen gives an error saying "backup client not installed".

 

2. Added :25 to the end of the SMTP server IP address and notifications work again.

 

3. No feedback on the preferences screen that your test email has been sent - but it has as long as you don't see an error message reported.

Share this post


Link to post
Share on other sites

Some users are now required to under the port number after the IP/mail server address. This is the result of a change we made that now allows users to pick something other then the default port.

 

For some reason, not everyone needs to include the default port number.

Share this post


Link to post
Share on other sites

Hi, We have the restrospect software running on the mail server. Even after adding the :25 after the IP address I still get an error - this time-535 backup client: network unavailable. We run a simple peer to peer network and therefore do not have a DNS server. Any other options for resolving this issue introduced in 7.6.123?

Share this post


Link to post
Share on other sites

Hi Robin. I did run this yesterday but forgot to add it to the post. This is the operations log

 

soctSetThread: socket thread now 0xe8c

smtpOpen: connecting using port 6,400

soccOpen: socket send buffer size is 65,536

soccOpen: socket recv buffer size is 65,536

soccOpen: connect() failed with error 10053

smtpOpen: connection failed using port 6,400

smtpSend: "QUIT"

soctPreDispose: maximum queue depth was 0

 

Share this post


Link to post
Share on other sites

For what it's worth, E-mail from our Windows 2008 based Retrospect server (version 7.6.123) works without a problem. So I don't think that functionality is broken, which Robin speculated about in his post of 12-24-08 07:20 AM.

 

Could it be your server's firewall is blocking outbound access to the smtp-server?

 

Did you specify a functioning from-address in Retrospect's preferences? Some mail servers check for this and reject when there is no from-address specified.

Share this post


Link to post
Share on other sites

Nothing has changed on the mail/retrospect server. It was only when I was adding some more NAS drives and creating backup sets that I realised the mail wasn't working.

Share this post


Link to post
Share on other sites

Ah, sorry.

 

I just realised you were not the original poster of the thread (which seems to be kind of old *L*).

 

Maybe you should post a new thread with a more extensively formulated question?

Share this post


Link to post
Share on other sites
Hi Robin. I did run this yesterday but forgot to add it to the post. This is the operations log

 

soctSetThread: socket thread now 0xe8c

smtpOpen: connecting using port 6,400

soccOpen: socket send buffer size is 65,536

soccOpen: socket recv buffer size is 65,536

soccOpen: connect() failed with error 10053

smtpOpen: connection failed using port 6,400

smtpSend: "QUIT"

soctPreDispose: maximum queue depth was 0

SMTP is normally port 25, not 6400.

 

What does error 10053 mean (in the context of your SMTP server)?

 

Does the SMTP server require authentication?

Share this post


Link to post
Share on other sites

Hi Robin

 

Nothing has changed apart form the upgrade to 123. My server has always asked for authentication. I will follow your link tomorrow but as retrospect is the only thing to have changed I have my suspicions shall we say.....

Regards

Robin

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×