Jump to content
Sign in to follow this  
hvar

Problem with AIT-5 drives in Qualstar TSL4440

Recommended Posts

I have serious problems getting Retrospect to see two AIT-5 drives in a Qualstar TSL4440.

 

Current hardware setup:

Mac OS 10.5.5 on a G5, 2GHz, 4.5 GB RAM

Retrospect Server 6.1.230 + Driver Update 6.1.15.101

ATTO ULD4S SCSI card, driver 4.3.1, firmware 18.jan 2008

QualStar TSL4440 with two AIT-5 drives, firmware 2.26

 

Problem: The setup works just fine, except for only one AIT-drive is visible (I can live with that). It can run stable for months. It is OK to turn mac off or restart Mac.

HOWEVER: If the Qualstar is powered off Retrospect will not see any AIT-drives when it is turned back on. All tape slots is visible, and I can move tapes just fine, but no AIT-drives. I can tickle it for hours to get them visible again.

 

The woodoo to get it visible again has been any random combination of: Changing SCSI-ID, deleting prefs, using "clear all device info", resetting NVRAM in Open Firmware, moving ATTO-card to new slot, removing battery from Mac motherboard, resetting P-RAM, uninstalling and reinstalling ATTO driver, changing ATTOs SCSI setup etc. At some point after x hours/days one of the AIT-drives will suddenly reappear! Then everything is nice and dandy for weeks/months - until the Qualstar is powered off.

 

It seems to be random which of the two AIT-drives will be visible when it finally becomes visible again.

 

It has been running fine for 4 months (OS 10.5.3 I think), until a week ago when a main fuse blew. (No UPS on the jukebox! arrgh)

Now I cannot get any tape drives back, and I am stuck without backup and without restore.

 

The Qualstar was for several years used flawlessy with a Solaris machine, but during The New Backup Plan we moved it to Retrospect server on a Mac.

The problem I describe has been present all the time on the Mac. Original setup was on Mac OS 10.4.8, but upgraded thru 10.4.11, 10.5.1, 10.5.2, 10.5.4 and 10.5.5

 

Older versions of ATTO firmware and drivers has also been used when they were current. Retrospect has also been updated once or twice without any difference.

 

Current SCSI-setup: Loader SCSI-ID 4, Drives: 1 and 2. One very short SCSI-cable, terminated correctly.

 

No other SCSI-devices on bus.

No other PCI-cards present.

Replacing the PCI-card with another ATTO ULD4S card made no difference.

Replacing SCSI-cables makes no difference.

Replacing the Mac makes no differece.

 

If I turn on extensive SCSI-logging, the two drives are reported with identifiers so I think Retrospect does see the drives somehow:

 

DeviceAccess: Closed Device 0|4|0 QUALSTAR|TLS-4440|226a

[...]

drive id 1 has identifier "0007900538"

drive id 2 has identifier "0007900536"

[...]

 

Can anyone teach me the dance to get them visible again?

 

HÃ¥vard

Share this post


Link to post
Share on other sites

What is showing up in Apple System Profiler? If the devices are not showing up in the device table there, then there is no way that Retrospect can access the devices.

Share this post


Link to post
Share on other sites

This is what System Profiler gives me. I am not sure if the drives actually show up there when it works either - anyone out there with a working Qualstar TLS-4440 that can post what it should look like?

 

SCSI Parallel Domain 1:

 

Initiator Identifier: 7

 

SCSI Target Device @ 4:

 

Manufacturer: QUALSTAR

Model: TLS-4440

Revision: 226a

SCSI Target Identifier: 4

SCSI Device Features:

SCSI Initiator/Target Features:

Peripheral Device Type: 8

 

SCSI Logical Unit @ 0:

 

Manufacturer: QUALSTAR

Model: TLS-4440

Revision: 226a

SCSI Logical Unit Identifier: 0

 

 

Share this post


Link to post
Share on other sites

I see I have been unclear in my original post:

Current SCSI-setup: Loader SCSI-ID 4, Drives: 1 and 2.

 

The AIT-5 drives are LUN 1 and 2 on the Loader SCSI ID 4.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×