Jump to content
jdpal

Bad items in mailbox - how to locate?

Recommended Posts

Hi,

 

When I back up some users' mailboxes, I get errors like this:

 

- 10/31/2008 10:44:43 PM: Copying User1 on Mailserver

T-14: MBDataInputStream::PrepareLongProperty: Failure (winerr = 0x8004011b) to read long property 0x1009.

File "User\Deleted Items\0000000041777b9ace11e2449d6126c7f83fd2d20700ba5af3afafc8934ea61d1d91775c25de00002b034f7c0000ba5af3afafc8934ea61d1d91775c25de000034b5e2b30000": can't read, error -1012 (feature unsupported)

10/31/2008 10:45:12 PM: Snapshot stored, 3,465 KB

10/31/2008 10:46:38 PM: 1 execution errors

Remaining: 1 files, 18 KB

Completed: 45 files, 1,174 KB

Performance: 0.7 MB/minute

Duration: 00:01:55 (00:00:26 idle/loading/preparing)

 

 

- 10/31/2008 10:46:40 PM: Copying User2 on Mailserver

File "User2\Calendar\000000001fbf487112efd946bb973eb441dd58450700ba5af3afafc8934ea61d1d91775c25de00002b02c3d1000026a307ad8fe4b84794c046b9a5c148de0000349ad6070000": can't read, error -1101 (file/directory not found)

10/31/2008 10:48:01 PM: Snapshot stored, 21.1 MB

10/31/2008 10:50:21 PM: Execution completed successfully

Remaining: 1 files, 24 KB

Completed: 149 files, 10.1 MB

Performance: 4.5 MB/minute

Duration: 00:03:40 (00:01:26 idle/loading/preparing)

 

I think these are bad/corrupted items within the users mailbox. I was wondering if anyone knows how to identify which items these are (based on the data given in the error)? From there I could ask the user to delete the item.

 

Thanks!

Share this post


Link to post
Share on other sites

Try going to the history tab in the activity monitor. Highlight the backup item. You will usually see an "errors" button at the bottom. This errors button should display the problem files.

Share this post


Link to post
Share on other sites

Hi Mayoff,

 

Thanks for the quick response. Unfortunately the errors button is greyed out for everything in my history log.

 

This is Retrospect 7.6.111

Share this post


Link to post
Share on other sites

To go ctrl-alt-p-p in Retrospect. Set Mailbox Backup logging to 6 and try the backup again. It may give more detailed info in your log.

Share this post


Link to post
Share on other sites

Hi Mayoff,

 

I changed the mailbox backup logging level to 6 and restarted Retrospect. I then ran the mailboxes script again. No further information is reported in the log and I still get the same exact errors as before. I still cannot click on the "errors" button in the job history log.

 

Any other suggestions?

 

 

 

Share this post


Link to post
Share on other sites

Hi Mayoff,

 

I set the trees and volumes debug to 6, and the backup job generated a nice 100MB log. Unfortuantely Retrospect was not able to export the entire log, it gave up after about 740,000 lines. That cut off the beginning of the log which may be where the useful info is.

 

Is there any reason why the errors button is greyed out?

Share this post


Link to post
Share on other sites

Just do a backup of that mailbox instead of running the entire script. Hopefully that will narrow down the cause of the error.

 

Not sure why the button is grayed out

Share this post


Link to post
Share on other sites

You can try to define the calendar or deleted items folder as a subvolume and just back up that folder since this is the one reporting the error.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×