Jump to content
jaimer00

Re: Exchange 2007 rbu account authentication failure

Recommended Posts

i'm getting similar errors any ideas. I get the same with my RBU account

 

TMapiManager::Reinitialize: Creating new MAPI session.

CreateProfileAndSession: ConfigureMsgService(*****,=administrator) returned 0x80040115.

TMapiConnection::TMapiConnection: Unable to use profile, win error 0x80040115

TMapiManager::Reinitialize: couldn't intialize mailboxes due to a prior error.

Retrospect error code error -3408 (unknown)

Reported by function mblcpMailboxTestLogin

Network error: Exchange is not answering and may need restart or reboot.

 

Share this post


Link to post
Share on other sites

Are these rights errors?

 

Error returned from an ESE function call (-1,003).

 

MapError: unknown Windows error -1,003

TWDBExchangeServer2000Base::BackupRead: HrESEBackupReadFile failed, winerr -1003, error -1004

Exchange_Vol::BackupRead: BackupRead failed error -1004 (Database Backup/Restore error)

File "First Storage Group\Mailbox Database": can't read, error -1004 (Database Backup/Restore error)

TWDBExchangeServer2000Base::GetLogFilesSize: HrESEBackupGetLogAndPatchFiles failed.

HrESEBackupGetLogAndPatchFiles(0c8000209) -- The backup call is out of sequence.

 

HrESEBackupReadFile --

Error returned from an ESE function call (-1,003).

 

MapError: unknown Windows error -1,003

TWDBExchangeServer2000Base::BackupRead: HrESEBackupReadFile failed, winerr -1003, error -1004

Exchange_Vol::BackupRead: BackupRead failed error -1004 (Database Backup/Restore error)

File "First Storage Group\zzz LOG": can't read, error -1004 (Database Backup/Restore error)

vlocRDiskDoFileCreate: device number = 0x1

TWDBExchangeServer2000Base::StopDatabaseBackup: HrESEBackupCloseFile failed., winerr -939585628, error -3662

8/20/2008 8:55:05 AM: Comparing First Storage Group

8/20/2008 8:55:05 AM: 2 execution errors

Duration: 00:00:01

 

 

- 8/20/2008 8:55:05 AM: Copying Second Storage Group

Backup type: Full

HrESEBackupReadFile --

Error returned from an ESE function call (-1,003).

 

MapError: unknown Windows error -1,003

TWDBExchangeServer2000Base::BackupRead: HrESEBackupReadFile failed, winerr -1003, error -1004

Exchange_Vol::BackupRead: BackupRead failed error -1004 (Database Backup/Restore error)

File "Second Storage Group\Public Folder Database": can't read, error -1004 (Database Backup/Restore error)

TWDBExchangeServer2000Base::GetLogFilesSize: HrESEBackupGetLogAndPatchFiles failed.

HrESEBackupGetLogAndPatchFiles(0c8000209) -- The backup call is out of sequence.

 

HrESEBackupReadFile --

Error returned from an ESE function call (-1,003).

 

MapError: unknown Windows error -1,003

TWDBExchangeServer2000Base::BackupRead: HrESEBackupReadFile failed, winerr -1003, error -1004

Exchange_Vol::BackupRead: BackupRead failed error -1004 (Database Backup/Restore error)

File "Second Storage Group\zzz LOG": can't read, error -1004 (Database Backup/Restore error)

vlocRDiskDoFileCreate: device number = 0x1

TWDBExchangeServer2000Base::StopDatabaseBackup: HrESEBackupCloseFile failed., winerr -939585628, error -3662

8/20/2008 8:55:06 AM: Comparing Second Storage Group

8/20/2008 8:55:06 AM: 2 execution errors

Duration: 00:00:01

 

8/20/2008 8:55:06 AM: 4 execution errors

Total duration: 00:00:02

 

Share this post


Link to post
Share on other sites

You may want to unlicense and then relicense exchange from the configure>Volumes Windows and then configure the backup using the steps in the URL above.

 

What version of Retrospect is this?

Share this post


Link to post
Share on other sites

i was successful now and followed the article to the t. When i go to restore is do not get any snapshots to restore also if i right click under volumes exchange mailboxes, it will not authenticate with RBU, and i verified all settings. Latest version v7.6.111, exhange 2007sp1, windows server 2008

 

+ Executing Immediate Backup at 8/20/2008 9:06 AM (Execution unit 1)

To Backup Set Exchange_Backup...

 

- 8/20/2008 9:06:15 AM: Copying First Storage Group

Backup type: Full

vlocRDiskDoFileCreate: device number = 0x1

8/20/2008 9:06:21 AM: Comparing First Storage Group

vlocRDiskFileOpen: device number = 0x1

vlocRDiskFileOpen: device number = 0x1

8/20/2008 9:06:22 AM: Execution completed successfully

Completed: 2 files, 96.1 MB

Performance: 1646.2 MB/minute (1152.3 copy, 5761.8 compare)

Duration: 00:00:07

 

 

- 8/20/2008 9:06:22 AM: Copying Second Storage Group

Backup type: Full

vlocRDiskDoFileCreate: device number = 0x1

8/20/2008 9:06:25 AM: Comparing Second Storage Group

vlocRDiskFileOpen: device number = 0x1

vlocRDiskFileOpen: device number = 0x1

8/20/2008 9:06:26 AM: Execution completed successfully

Completed: 2 files, 35.1 MB

Performance: 1401.2 MB/minute (1050.9 copy, 2101.8 compare)

Duration: 00:00:03

 

8/20/2008 9:06:26 AM: Execution completed successfully

Total performance: 1572.7 MB/minute

Total duration: 00:00:10

 

Share this post


Link to post
Share on other sites

What exactly happens when you try to authenticate using the RBU account?

 

What groups is the RBU account a member of?

 

Did send an email to the RBU account to initialize the account?

 

Did you install MAPI on the exchange server?

Share this post


Link to post
Share on other sites

No errors in event log, it says it ran successfully.

 

Logged on as RBU and it ran successfully but still no snapshots, and i always get a prompt that says "Sorry authentication failed, try again" this is on the exchange mailbox logon, when i right click on exchange mailbox. Now when i right click on exchange server, and logon as it accepts my credintials. This is all under my backup source selections screen.

Share this post


Link to post
Share on other sites

We had another user reporting something similar recently and creating a new RBU user account seemed to solve the problem for them. Did you restart the exchange server after installing MAPI?

 

You may need to call tech support so we can help with more detailed debugging.

Share this post


Link to post
Share on other sites

Hi Mayoff,

 

In your link (http://kb.dantz.com/display/2/articleDirect/index.asp?aid=9633&r=0.7642938) on how to setup the user baccount to backup Exchange 2007, it notes that you must check the option to allow Outlook 2003 support during the Exchange 2007 SP1 install. Okay not a problem, but I have already installed Exchange 2007 SP1 and if I try to re-run the installer I do not have an option to reinstall.

 

Is there an option in Exchange 2007 to simply enable this feature?

 

Please advise

Share this post


Link to post
Share on other sites

So this is a requirement? BackupExec 12d does not need this. Will Retrospect have full native support for Exchange 2007 in the near future?

 

Thanks,

Niles

Share this post


Link to post
Share on other sites

Enabling Outlook 2003 compatibility in EX07 means to enable public folder distribution of the Offline Address Book in Version 3.

To do so start the Exchange Management Console, go to Organization Configuration - Mailbox. In the register for the Offline Address Book select yours and open its properties. Make sure that Client Support is enabled for Outlook 2003 (Version 3) and public folder distribution is enabled.

 

Philipp

Share this post


Link to post
Share on other sites

Hi Philipp,

 

Thank you for the instructions. Did this solution work for you? I still get authentication errors when I right click the Mailboxes under Configure> Volumes and select Login as. I can authenticate with the First Storage Group, but the Mailboxes.

 

 

Thanks,

Niles

Share this post


Link to post
Share on other sites

Niles,

 

at the end, we managed to get Retrospect to work with EX07. But it was a bit more complicated than expected.

We added our Exchange Server to an existing EX03-server, so there might be some settings that werde done by the Exchange setup to ensure backward compatibility.

 

At the end we could track the problem down to a GPO setting - but we couldn't track it down to a specific setting. Did you make any modifications to the group policy?

 

Philipp

Share this post


Link to post
Share on other sites

Jst to put this out there. I was running Backup Exec 12d 60 day Trial with no major issues and none with backing up Exchange 2007 and mailboxes. So I do not understand why Retrospect cannot do the same.

 

 

Thanks,

Niles

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×