Jump to content
KenBrey

Configure SMPT port for notifications

Recommended Posts

Our new Exchange 2008 server installation has it's SMTP port 587. Retrospect trys to send through port 25. Can I configure the port that Retrospect will for the SMTP server on?

Share this post


Link to post
Share on other sites

Check the box "my outgoing server requires authentication". My understanding is that this forces Retrospect to use 587

Share this post


Link to post
Share on other sites

Selecting authentication did not solve the problem. My exact error message is: E-mail notification failed: error -592 (invalid response from SMTP server)

 

Is there any further diagnostics to be found about the invalid response is?

Share this post


Link to post
Share on other sites

Type ctrl-alt-p-p (letter P twice while holding ctrl-alt). Change Network Logging under Debug Logging from 3 to 7.

 

Reproduce the error. The operations log will contain the response info reported directly by your mail server.

Share this post


Link to post
Share on other sites

I performed the procedure as you described. I think these are the important lines:

 

smtpSend: "AUTH LOGIN"

smtpWait: "504 5.7.4 Unrecognized authentication type"

smtpReset: AUTH LOGIN expected 334, response 504

smtpSend: "QUIT"

 

What is the authentication type that Retrospect is expecting to use?

Share this post


Link to post
Share on other sites

It is your mail server that is reporting the authentication failure.

 

The 504 5.7.4 is a standard SMTP error. You can probably google that error and learn more about it.

Share this post


Link to post
Share on other sites

I'm getting the same -592 error.

smtpWait: "220 *email server* ESMTP"

smtpOpen: connection established "*email server*"

smtpSend: "EHLO hostname"

smtpWait: "250 STARTTLS"

smtpSend: "AUTH LOGIN"

smtpWait: "538 Encryption required"

smtpReset: AUTH LOGIN expected 334, response 538

 

Does Retrospect support TLS or SSL for a secure login?

 

 

 

Share this post


Link to post
Share on other sites

I pointed my SMTP server to a server run by my ISP that only uses IP filtering for authentication. I gave up on using my Exchange 2007 SMTP server with Retrospect. I switched several other applications to use the external SMTP server as well.

Edited by Guest

Share this post


Link to post
Share on other sites

I have to say that I REALLY think you need to implement support for TLS. Snow Leopard server has it enabled by default and I can't get any notifications from any of the Retrospect installations that I support because of this!!!!

 

It's highly annoying, since it's not that new or esoteric a protocol.

Share this post


Link to post
Share on other sites

This really should be on a list of planned features to add. Many ISPs these days block port 25, and only allow email to be sent over secure ports such as 465. I am unable to even access a different server from one of my clients computers over 25.

 

Doesn't seem like a difficult feature to add. Thanks

Share this post


Link to post
Share on other sites
Guest

The correct approach is to provide a LAN-based SMTP server that does not require authentication from well known services. The point of TLS for most users is to encrypt the AUTHentication process. For almost all services on a LAN that report events via email, with well controlled LAN IP addresses, there is generally little need for client->server authentication - IP whitelisting is sufficient.

 

Having said this, there is little reason to restrict the TCP port to 25 - providing for alternate ports is standard and trivial.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×