Jump to content
sinking

Restoring databases - Trouble writing files, error -1004

Recommended Posts

I am getting this error every time I try to restore a database:

 

 

+ Executing Restore database from Backup at 20/05/2008 11:45 (Execution unit 2)

20/05/2008 11:45:16: Connected to db-server

To volume TestRestore on db-server...

 

- 20/05/2008 11:45:16: Restoring from DB-SERVER

Restore type: Full

Trouble writing files, error -1004 (Database Backup/Restore error)

20/05/2008 11:47:54: Execution incomplete

Remaining: 1 files, 2,396 KB

Completed: 0 files, zero KB

Performance: 0.0 MB/minute

Duration: 00:02:37 (00:00:34 idle/loading/preparing)

 

This happens if I restore a database to its original location, to a new database on the same server, to a new database on a different sql server.

 

I have also tried authenticating as RBU, the domain admin account and the sa account. All with the same error.

 

The databases seem to be backing up fine.

 

The setup is:

 

Retrospect Multi Server 7.5.387

Driver Update and Hot Fix, version 7.5.13.100

Running on a Windows 2003 Server, fully patched.

 

The client is SQL2000 all service packed, with Retrospect Client version 7.5.116.

 

Any ideas?

 

Adrian.

Share this post


Link to post
Share on other sites

This error is being reported by the SQL server itself. Check the enterprise manager logs for errors. You can get more error info in debug logging:

 

hold ctrl-alt and hit the letter P twice. ctrl-alt-p-p. Under debug logging, set Trees and Volumes logging to 6. Reproduce the error. Check the operations log. It will display the hex code reported by SQL during the restore. You can then google the hex code.

Share this post


Link to post
Share on other sites

Hi Robin, thank you! That pointed me in the right direction. Because we use named instances I had to go into Options - More Choices - SQL Server - and set the custom path for data and log files to the local path of the data folder for the named instance on the destination server.

 

All works brilliantly now.

 

Thank you!

 

Adrian.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×