Jump to content
cgiandomenico

Can't backup Iomega NAS. error -1017 insufficient permissions

Recommended Posts

I am attempting to backup an Iomega NAS model: "Home Network Hard Drive" with Retrospect 7.5. This NAS uses an unknown operating system and the drive is formatted as FAT32. The NAS is part of a windows Workgroup. Retrospect 7.5 is able to preview the contents of NAS volumes from within the Immediate Backup pane. I have tried using all reasonable automatic logon credentials including: nothing, Administrator, Local User, & the NAS Administrator. The backup is failing with an error -1017. The details are shown below. I haven't loaded any backup client software on the NAS. It doesn't have an interface to permit program installation. The Iomega NAS came with Retrospect Express HD 2.0 and I have successfully backed it up using this software. I had assumed if a cut down version of Retrospect worked with this NAS my Retrospect Professional would too...

 

Does anyone have any thought about what might be happening and how to fix it?

 

+ Retrospect version 7.5.508

Launched at 3/24/2008 10:22 AM in user account WELLREAD3\Administrator

+ Driver Update and Hot Fix, version 7.5.13.100

 

+ Executing Immediate Backup at 3/24/2008 10:24 AM

To Backup Set junk...

 

- 3/24/2008 10:24:54 AM: Copying Pictures on Iomega500

Can't initialize Snapshot file, error -1017 (insufficient permissions)

3/24/2008 10:24:55 AM: Execution incomplete

Duration: 00:00:00

 

Share this post


Link to post
Share on other sites

I didn't think this document applied because I had configured the NAS to allow complete access to all Workgroup members without passwords. However, I also experimented with share permissions and learned something. (Note, this NAS is very basic, it only supports share-level protection with only two access states: Full Access/No Access.) When I assigned password protection to a share I was able to produce the -1017 error in Retrospect by suppling an incorrect username & password when prompted while making a subvolume. I could access the subvolume by supplying the correct credentials. I could also access any subvolume without supplying credentials if the share was not password protected.

 

Next I setup an Immediate Backup and entered the correct login credentials in the "Enter network password" automatic login dialog. I also set up Retrospect to startup under my account which is able to access the NAS shares. I checked the automatic login properties of the backup set which is located on my local hard drive. These properties were greyed out. I think this covers all three login aspects covered by the document.

 

I ran the immediate backup and got the same error as before: Can't initialize Snapshot file, error -1017 (insufficient permissions)

 

Share this post


Link to post
Share on other sites

It seems the problem with the NAS was coincidental. All of my backups, including of local drives, are failing with a -1017 error. I rolled back Windows to a time when Retrospect was working. No luck. Next steps are a repair of Windows followed by a reinstall of Retrospect.

Share this post


Link to post
Share on other sites

I rolled back Windows to a time when Retrospect was working.

 

What Windows OS are you using? There have been some other 1017 problems reported that are known and are being worked on.

Thanks,

-Jeff

Share this post


Link to post
Share on other sites

Windows XP SP2. I have resolved the 1017 error issue. While I do not know the exact cause I believe it was related to some modifications I made to my system that were unrelated to retrospect. While investigating the problem I discovered that regedit could not export registry keys. The solution I found was:

 

(1) Restore Windows using an image file (not made with retrospect).

(2)Restore using retrospective to a recent time point when both retrospect and regdedit worked.

 

I can now backup my local drive and my NAS without incurring any 1017 errors.

 

Thank-you for your follow-up.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×