Jump to content
Sign in to follow this  
jfucci

Getting UIR to work

Recommended Posts

I cannot seem to get UIR to work on my system. I have installed it, and it says it has installed correctly. However, when I try to get to the web page, I get a 404 error. I have read and followed the directions in KB article 8353, but I still get this error. I am running Windows Small Business Server 2003 Standard with all available updates applied, Retrospect 7.5 Small Business Server Standard, and have the UIR add-on installed.

 

Any help will be appreciated.

 

Thanks!

 

John Fucci

Share this post


Link to post
Share on other sites

How about KB article 8344?

 

If users are unable to reach the User Initiated Restore (UIR) webpage due to a error 404, you may need to try and run the ASP.NET IIS Registration tool on the backup server.

Enter the following text at the Run Command on the Retrospect Backup Server:

 

C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\aspnet_regiis.exe -i

 

If the path to "aspnet_regiis.exe" is different than the one is listed above, make sure to enter the correct path

Share this post


Link to post
Share on other sites

Quote:

How about KB article 8344?

 

If users are unable to reach the User Initiated Restore (UIR) webpage due to a error 404, you may need to try and run the ASP.NET IIS Registration tool on the backup server.

Enter the following text at the Run Command on the Retrospect Backup Server:

 

C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\aspnet_regiis.exe -i

 

If the path to "aspnet_regiis.exe" is different than the one is listed above, make sure to enter the correct path

 


 

Yes, I have also run this procedure, and I still can't get to the web page. And if I try to reach the page using http://computername/myrestore/default.aspx?admin, I get the following error:

 

The resource cannot be found.

Description: HTTP 404. The resource you are looking for (or one of its dependencies) could have been removed, had its name changed, or is temporarily unavailable. Please review the following URL and make sure that it is spelled correctly.

 

Requested URL: /myrestore/default.aspx

 

 

This is a fairly new server (about a month), which came with Windows 2003 Small Business Server Standard pre-installed. Poking around the server a bit, I see that both .NET Framework 1.1 and .NET Framework 2.0 are installed. Could this be causing a conflict?

Share this post


Link to post
Share on other sites

OK, I have messed around a bit more and now finally have it working. When I installed UIR, the virtual directory was installed under the website companyweb, which is something that gets installed by default for Sharepoint with SBS 2003. In order to get to this website, instead of using http://computername, you need to use http://companyweb. This is something I still need to work with, as companyweb does not resolve with DNS. But even when I try to bring it up on the server itself, I get errors from ASP.NET. It seems to some kind of configuration issue with Sharepoint and ASP.NET for this particular website. Again, it's something I still need to work with in the future, as Sharepoint is not an issue right now.

 

In order to get it working, I manually created the virtual directory myrestore under the default website, and then moved the corresponding directory for myrestore under the directory structure for the default website. I can now get to my restore through the URL http://computername/myrestore, and have successfuly restored some test files.

 

So I guess the question now is why did the install routine pick that particular website to install the myrestore virtual directory? Perhaps the install for UIR should be modified so that the website where the myrestore virtual directory can be manually chosen.

 

Also, with all the messing around I have doen, I have uninstalled .NET Framework 1.1, and have just .NET Framework 2.0 running. UIR seems to work just fine so far.

Share this post


Link to post
Share on other sites

I also had this problem, and I want to document the details for others.

 

In addition to running the ASP.NET IIS registration tool as described above for the .NET Framework 2.0, I had to go back into the IIS Manager and allow the ASP.NET v.2.0.50727 Web Service Extension. This extension was newly installed with the registration action.

 

I was also advised by a network admin to enable "Script source access" on the Home Directory tab of the site properties. I then had to select and approve all the scripts associated with UIR.

 

After this, I restarted the site before testing. All seems to work well now.

Share this post


Link to post
Share on other sites

Actually, after reading all the replies, I searched for the location of the companyweb\myrestore "actual" directory, which was in C:\InetPub\companyweb.

Then I copied it (probably could have moved it) up a level to C:\InetPub.

Then in the Internet Information Services management tab, I right clicked on "Default Web Site" and created a new virtual directory called "myrestore" and pointed it at the copied directory (actually I bet I could have done without copying!).

That was all that was necessary.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×