Jump to content
Sign in to follow this  
jccl2

Cant restore differential database backup

Recommended Posts

Hello,

 

I need to restore a database from differential backup, checked the properties and have two media to restore, when select the differential backup the button restore database stay gray but, if select option and unselect "Restore any needed intermediate snapshots" the restore database button works, they try to make the restore but back with this errors:

 

+ Executing Restore database from Backup at 23/10/2007 10:11 A (Execution unit 1)

23/10/2007 10:11 A: Connected to Server-A1

To volume Server-A2_1123568704 on Server-A1...

 

- 23/10/2007 10:11 A: Restoring from SecondWeek(W6)

Restore type: Differential

T-7: MapError: unknown Windows error 3.117

Trouble writing files, error -1004 (Database Backup/Restore error)

23/10/2007 10:12 A: Execution incomplete

Remaining: 1 files, 31,6 GB

Completed: 0 files, zero KB

Performance: 0,0 MB/minute

Duration: 00:00:35 (00:00:32 idle/loading/preparing)

 

 

Any Ideas ???

 

Thanks.

Share this post


Link to post
Share on other sites

The error is coming directly from the SQL Server itself. What happens if you try to restore the full backup first?

 

You can't restore the Differential part of the backup without the full backup being restored first. I suspect the button was greyed out because the full backup could not be found.

Share this post


Link to post
Share on other sites

I can see the full backup on snapshots but on properties of the differential its show the oldest full backup and the both tapes are inside of the library. If the option "Restore any needed intermediate snapshots" selected the button still greyed. I can restore the full backup but when tried restore the differential come the errors.

On the snapshots have 2 differential backup's at same day with different time, of the same database, can be a problem ?

 

Event Viewer Error only when the differential of day 10/18/2007 (where have 2 diff at same day) are tried restored:

 

Event Type: Error

Event Source: SQLVDI

Event Category: None

Event ID: 1

Date: 23/10/2007

Time: 11:42 A

User: N/A

Computer: SERVER-A1

Description:

SQLVDI: Loc=IdentifySQLServer. Desc=MSSQL$SERVER-A1. ErrorCode=(1060)The specified service does not exist as an installed service.

. Process=3084. Thread=3884. Client. Instance=SERVER-A1. VD=.

 

 

Thanks.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×