Jump to content
Sign in to follow this  
nilsheijmans

Catalog corrupt or heavily damaged?? Or is there something else wrong?

Recommended Posts

I run Retrospect Multi Server version 7.0.326 on a single Server and backup multiple clients.

 

Last week I got an error which stated that my database can't be read. When I tried to repair I got a message telling me that it isn't a catalog or it was heavliy damaged. The copies of the database I keep aside the originals also give the same error.

I restored the database from last weeks backup (before I got the errors) from another backup server (Veritas Backup Exec) and imported the catalog. This resulted in the same error.

I also can't recreate from backup tapes, says there's no catalog on tape. I am sure that the checkbox "fast catalog rebuild" is/was checked.

 

So I think my Retrospect might be corrupting my catalogs.

I can reinstall Retrospect, but I want to make sure that that will solve my problem, and I want to know if it will not rise again in the (near) future.

 

Hope to hear from someone soon.

Share this post


Link to post
Share on other sites

I have received this error for 8 backup sets today, in the non Multi-swerver environment. The only change which has occurred which is signifiicant regarding those Backup Sets, is that I've installed the .370 build, and this is the first backup since upgrading. My sympathy for problems voiced elsewhere on these forums, has just increased by a factor of 10.

Share this post


Link to post
Share on other sites

Another characteristic may be that I went from build .285 to .370, skipping the .324 build linked by Robin Mayoff in one of his posts. Could it be that something in .370 relies upon a change made in .324, such that the Catalogs are perceived as corrupt if one skips the .324 update?

Share this post


Link to post
Share on other sites

I received the message prior to updating Retrospect!!

Nor the "old" or the newest build changed anything, still the same message.

 

I hope I don't have to rebuild catalog from like 80 tapes!!

Share this post


Link to post
Share on other sites

Quote:

So I think my Retrospect might be corrupting my catalogs.

 


 

Retrospect does corrupt catalogs, but it almost always occurs in the context of Retrospect crashing while it's writing to the catalog. Could it have been that case that happened recently?

 

Quote:

I also can't recreate from backup tapes, says there's no catalog on tape.

 


 

It should be asking for the most recent tape member. You could try with an earlier member and work your way back. Ultimately, though you may have to rebuild from scratch.

Share this post


Link to post
Share on other sites

Thnx for the reply.

 

I might have had a crash at some point in time (who doesn't).

But the strangest thing is that the copies that I made of the files (in case of corruption) are also corrupt and can't be accessed.

I'm working through the tapes to find if I can recreate the catalog from some point.

Rebuilding from tapes will take about 10 hours per tape. So I'll be done in september orso :-(

 

I'll post my further findings.

 

Grtz

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×