Jump to content
Sign in to follow this  
IanR

Error 1100

Recommended Posts

I am using Desktop version 5.6 and a Linksys NSLU2 on a XP Pro machine. I experienced an error 1100, invalid handle, after several successful backups. Two other computers running XP Home on my home network were not experiencing the error. Two days later these other computers experienced the same error. What does the error mean, why does it happen, and how do I fix it?

Share this post


Link to post
Share on other sites

This is for the last 2 days. I recreated the back up set a week ago to get the back up working again because of this error. Got a few successful backups (recycle and normal) done and the errors happended again.

 

+ Retrospect version 5.6.127

Automatically launched at 9/2/2004 1:00 AM

+ Retrospect Driver Update, version 2.3.127

 

+ Normal backup using Normal Backup 2B at 9/2/2004 1:00 AM

To backup set Backup Set B...

 

- 9/2/2004 1:00:15 AM: Copying Drive C (C:)

File "C:\Documents and Settings\Chris Rickman\Local Settings\Temp\Perflib_Perfdata_e88.dat": can't read, error -1020 (sharing violation)

MapError: unknown Windows error 23

can't read data, BackupRead failed, C:\WINDOWS\MEMORY.DMP, winerr 23, error -1001

File "C:\WINDOWS\MEMORY.DMP": can't read, error -1001 (unknown Windows OS error)

File "C:\WINDOWS\SoftwareDistribution\DataStore\DataStore.edb": can't read, error -1020 (sharing violation)

File "C:\WINDOWS\SoftwareDistribution\DataStore\Logs\edb.log": can't read, error -1020 (sharing violation)

File "C:\WINDOWS\SoftwareDistribution\EventCache\{52F265AC-FA3F-4908-AFBA-B7C06F354CA8}.bin": can't read, error -1101 (file/directory not found)

File "C:\WINDOWS\SoftwareDistribution\EventCache\{6DAD7617-3168-4EE9-9868-02F77360AE04}.bin": can't read, error -1020 (sharing violation)

File "C:\WINDOWS\Temp\ZLT05457.TMP": can't read, error -1020 (sharing violation)

9/2/2004 2:01:53 AM: Snapshot stored, 97.8 MB

9/2/2004 2:02:23 AM: Comparing Drive C (C:)

File "C:\Program Files\Common Files\Symantec Shared\VirusDefs\usage.dat": different modify date/time (set: 9/1/2004 9:12:25 PM, vol: 9/2/2004 1:11:34 AM)

File "C:\WINDOWS\WindowsUpdate.log": different modify date/time (set: 9/1/2004 10:48:13 PM, vol: 9/2/2004 1:11:33 AM)

File "C:\WINDOWS\Prefetch\RTHLPSVC.EXE-289FBD89.pf": different modify date/time (set: 9/1/2004 1:08:38 AM, vol: 9/2/2004 1:10:25 AM)

File "C:\WINDOWS\SoftwareDistribution\DataStore\Logs\edb.chk": different modify date/time (set: 9/2/2004 1:06:34 AM, vol: 9/2/2004 1:11:07 AM)

File "C:\WINDOWS\system32\wbem\Repository\FS\INDEX.BTR": different modify date/time (set: 9/1/2004 1:54:44 PM, vol: 9/2/2004 1:54:50 AM)

File "C:\WINDOWS\system32\wbem\Repository\FS\MAPPING.VER": different modify date/time (set: 9/2/2004 12:31:13 AM, vol: 9/2/2004 1:55:50 AM)

File "C:\WINDOWS\system32\wbem\Repository\FS\OBJECTS.DATA": different modify date/time (set: 9/1/2004 1:54:44 PM, vol: 9/2/2004 1:54:50 AM)

9/2/2004 2:07:52 AM: 14 execution errors

Completed: 397 files, 668.7 MB, with 1% compression

Performance: 105.7 MB/minute (93.3 copy, 122.3 compare)

Duration: 01:07:37 (00:54:57 idle/loading/preparing)

 

TFileappl.gifSetEOF: SetEndOfFile failed, \\Netlink\carhome2\Backup Set B.rbf, winerr 6, error -1100

Quit at 9/2/2004 2:08 AM

 

+ Retrospect version 5.6.127

Automatically launched at 9/3/2004 1:00 AM

+ Retrospect Driver Update, version 2.3.127

 

+ Normal backup using Normal Backup 2B at 9/3/2004 1:00 AM

TFileappl.gifSetEOF: SetEndOfFile failed, \\Netlink\carhome2\Backup Set B.rbf, winerr 6, error -1100

Can't access backup set Backup Set B, error -1100 (invalid handle)

9/3/2004 1:00:45 AM: Execution incomplete

TFileappl.gifSetEOF: SetEndOfFile failed, \\Netlink\carhome2\Backup Set B.rbf, winerr 6, error -1100

Quit at 9/3/2004 1:01 AM

Share this post


Link to post
Share on other sites

Hi

 

I would run a thorough scan disk on the problem machines and then defragment all of them. I know it sounds hokey but the defragment phisically moves file around the disk. Often having Windows read and re-write a damaged file is enough to fix strange file errors like this.

 

Thanks

Nate

Share this post


Link to post
Share on other sites

It does sound hokey. The Linksys NSLU2 formats the disks with its own proprietory format. The disks were formatted when they were hooked up to this device (just recently) before they could even become usable. Within a week this error started. The NSLU2 does have a scandisk function but no defragment utility. I just ran it and it found no errors. Note that if I recreate the back up set, I can get some backups before it errors again.

 

Linksys is promoting this product along with Maxtor USB drives, which come with Retrospect. One of the drives I have is a Maxtor. I can't be the only one reporting this problem. Can it have something to do with a USB 1 drive?

Share this post


Link to post
Share on other sites

Hi

 

You are more than welcome to contact Dantz Technical Support for official support. As explained in the forum welcome message, the forum is not Dantz Technical Support. It is a community based help system. Dantz makes every effort to post here regularly but sometimes post volume makes it impossible to get to everyone.

 

How large is the backup set that you are storing on the linksys drive? Are there any maximum file size limitations for that device? Are there any updates available from Linksys? This device emulates a windows server. There are often cases where that emulation is incomplete or incorrect, causing problems like what you are seeing.

 

Thanks

Nate

Share this post


Link to post
Share on other sites

I just purchased a Linksys EFG250 NAS device and am getting identical behavior. I can do a couple of backups and then they start failing with an Error 1100. I am backing up to 37 different backup sets whose sizes range from 1 to 12 gigabytes. Two sets started to fail with the 1100 error (a 4gig and a 7 gig set). I had been using an earlier model of the Linksys NAS device with 80 gig hard drives. It always functioned very well for me using the same backup parameters.

Share this post


Link to post
Share on other sites

Hi

 

Are you using a file backup set or a disk backup set? How large are the backups when they fail? Does linksys have any firmware updates available? Sad to say many NAS devices don't emulate Windows filesharing very well...

 

Thanks

Nate

Share this post


Link to post
Share on other sites

I did a full recycle back up followed by on normal backup of about 450 mb. The next normal backup failed with an 1100 error. As for the back up set size, when I look on the device the size is 15143232580. When I look in Windows it is 4,294,967,295. Note that Windows always shows this size when I backup and that doesn't seem to change. That was true before using the Linksys device as well. The device has a file size limit option at the user level but it is not enabled. I am unaware of any other limits. The previous poster was using a larger drive than I am without problems so I assume I am not hitting a limit if there is one.

Share this post


Link to post
Share on other sites

I just got the exact same error 1100 using the linksys NSLU2 and a Maxtor backup drive. Several good backups, then suddenly "invalid handle"

Share this post


Link to post
Share on other sites

With multiple people having the same error, Dantz needs to get on the ball and provide a solution for this problem.

Share this post


Link to post
Share on other sites

Happened to me AGAIN. ANy help here?????????

 

 

+ Executing Immediate Backup at 11/2/2004 9:32 AM

To Backup Set Backup Set C...

 

- 11/2/2004 9:32:50 AM: Copying DRAWINGS (G:)

11/2/2004 9:33:04 AM: Snapshot stored, 1,537 KB

11/2/2004 9:33:05 AM: Execution completed successfully

Completed: 119 files, 10.1 MB

Performance: 100.3 MB/minute

Duration: 00:00:14 (00:00:07 idle/loading/preparing)

 

- 11/2/2004 9:33:05 AM: Copying share on Storage

11/2/2004 11:00:49 AM: Snapshot stored, 3,496 KB

11/2/2004 11:00:53 AM: Execution completed successfully

Completed: 22227 files, 6.6 GB

Performance: 76.3 MB/minute

Duration: 01:27:45 (00:00:03 idle/loading/preparing)

 

- 11/2/2004 11:00:53 AM: Copying vmfg on server

11/2/2004 11:01:05 AM: Snapshot stored, 189 KB

11/2/2004 11:01:06 AM: Execution completed successfully

Completed: 2 files, 574 KB

Performance: 5.6 MB/minute

Duration: 00:00:12 (00:00:02 idle/loading/preparing)

 

11/2/2004 11:01:15 AM: Execution completed successfully

Total performance: 76.1 MB/minute

Total duration: 01:28:14 (00:00:22 idle/loading/preparing)

Quit at 11/2/2004 11:02 AM

 

+ Retrospect Express version 6.0.222

Launched at 11/5/2004 4:32 PM

+ Retrospect Driver Update, version 3.6.104

 

+ Executing Immediate Backup at 11/5/2004 4:34 PM

Can't access Backup Set Backup Set C, error -1100 (invalid handle)

11/5/2004 4:34:41 PM: Execution incomplete

Share this post


Link to post
Share on other sites

Hi

 

 

 

Yes I work for Dantz. But as stated in theWelcome message this forum is not Dantz Technical Support. Please contact them directly if you require faster responses.

 

 

 

What is the firmware version of your NAS device? Are there any updates available? Chances are very good that Retrospect is working perfectly but something on the NAS is causing trouble.

 

 

 

Thanks

 

Nate

Share this post


Link to post
Share on other sites

V2.3R25, which is the most current version.

 

The issue is not a faster response. The issue is a lack of response. The first post was 08/31/04. It's almost midway through November, there have been multiple users posting messages about the same problem and there has not been a single post from your company about how to fix the problem. There is not a single item in your knowledgebase that addresses the problem or even says what is means.

 

The implication of your statement that a user can't expect to use the forums to solve problems is ridiculous. That is why it exists. My expectation is that your company provide a solution. 2 1/2 months is more than sufficient time for that.

Share this post


Link to post
Share on other sites

Hi IanR

 

You are using a file backup set and Retrospect 5.6 correct? This backup set is stored on the NAS device. Does the NAS device emulate an NTFS file system or a Fat32 file system? As a test can you create a backup set on a file share of another native Windows machine? This will tell us if the problem is network communication from the backup machine or if the problem is related to writing data to the NAS device.

 

Again, If you require direct Technical Support from Dantz please contact them directly. If community based support is sufficient then post your questions here. Dantz does its best to participate in this forum. However there are often times when that is not possible.

 

Thanks

Nate

Share this post


Link to post
Share on other sites

Yes, that is correct. The Linksys NSLU2 is a device into which you connect external USB hard drives. Apparently it has it's own OS. To be able to use the drives that are connected to it, they must be formatted via the NSLU2. It is some type of proprietary format. While these drives are connected to this device they can be browsed from Windows machine as devices on the network. According to their documentation, if the drives were connected to USB ports on a Windows machine, they would be unreadable.

 

Prior to using the NSLU2, these same drives were connected to my computer and backups were done from this machine and others on my home network without this failure.

Share this post


Link to post
Share on other sites

Same problem here

maxtor 250 Gb external harddisk

Linksys NSLU2

 

First backup was OK

Additionals backups went wrong:

 

+ Normal backup using Dagelijkse backup at 29-11-2004 23:55

Can't access Backup Set Backup Set A2, error -1100 (invalid handle)

29-11-2004 23:55:52: Execution incomplete

Shutdown at 29-11-2004 23:56

Share this post


Link to post
Share on other sites

Hi

 

 

 

Not to point fingers but chances are good the NSLU2 isn't handling some network calls properly. This is not uncommon with devices that emulate windows file sharing. I suspect a permanent solution will require an update from Linksys.

 

 

 

Can you try a backup to a file share on a native Windows machine? This will help us pinpoint the NSLU2 as the cause.

 

 

 

Thanks

 

Nate

Share this post


Link to post
Share on other sites

I have done many back ups to a windows file share and it works without a problem. This error does not occur. Dantz should be concerned about this whether the NLSU2 is at the root of the problem or not. Linksys pushes Maxtor USB drive specials when selling this device. Maxtor includes your product with the drive.

 

Whether it makes any difference or not, from what I read on the internet, the OS on this device is Linux.

Share this post


Link to post
Share on other sites

Hi

 

It's not that Dantz isn't concerned. We get beat up over these NAS problems a lot. There just isn't anything we can do about it.

 

These BSD and Linux based devices use Samba which emulates a windows network server. That emulation is not always perfect. Samba is an open source project so there isn't a whole lot of accountability when things don't work right. It also means that the project is constantly changing in small increments. Some versions work, others don't, some new versions will break things that used to work.

 

On the whole Samba is great but it is still a work in progress. The problem with devices like the NSLU2 is that the Samba version can't be upgraded when problems arise.

 

Retrospect handles all network volumes the same no matter what OS they run. If the volume correctly emulates a Windows file share there are no problems. If something on the network volume causes errors there isn't anything Retrospect can do to get around it.

 

I'm not trying to make excuses here. Its just not as cut and dried an issue as many assume.

 

Thanks

Nate

Share this post


Link to post
Share on other sites

Guys, really, you will need deal with this problem, because v6.5 simply doesn’t work with a backup over LAN if the Backup Set file is more than 800Mb (in my case).

 

For example, I have two Backup Sets created, one is about 800Mb and the second is a bit more than 2,6Gb. So the first (the smaller one) worked just fine, but the second one failed but only after first time went OK:

 

Can't access Backup Set A error -1116 (can't access network volume)

Sometimes it’s giving me -1100 error

 

The worse thing is that this network share can be accessed by any other resource or even manually with no problems! But the only Dantz fails. And fails only after it’s scheduled to run for the second time (using Normal backup in my case)…

 

Backup hardware used:

1. Maxtor 250Gb External HardDisk

2. 250Gb LaCie EtherNet Disk Network Storage

 

So, as you can see I wasn’t able to make Dantz v6.5 work with 2 different HDDs!

 

(If you need more information please contact me via my e-mail)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×