Jump to content
Sign in to follow this  

Recovery from bad header in file backup set?

Recommended Posts

Short version:


Is there anything I can try to work around problems with backup set headers in a file backup set? Or have I lost everything from the bad header onwards?






Long version:


I made a backup of drive X to a file backup set on drive Y using Retrospect 5.0.205, creating a 26 GB file. I erased drive X, but when I tried to do the restore, Retrospect reported the catalog on drive Y was damaged. A recatalog also reports an error. I have been able to restore some of the files, I am wondering if there is anything I can do to recover more of the data from the file backup set?




Recatalog fails consistently:


Bad backup set header found (0x3937390d at 27,259,652).


Backup set format inconsistency (12 at 27259918)


6/13/2002 4:33:42 PM: 2 execution errors.


Completed: 67150 files, 26.5 GB




A Restore of the whole disk fails like this:


Backup set format inconsistency (10 at 27705978)


6/13/2002 1:38:21 PM: 1 execution errors.


Remaining: 14555 files, 2.5 GB


Completed: 52595 files, 24.0 GB




Trying to retrieve just one missing file which was not already restored also fails with the "Bad backup set header found" with a different offset for each file I have tried.




The file backup set is on a firewire hard drive, I did all the work so far on a Dual G4 450 MHz running Mac OS 9.2.2, I have trying running the recatalog from a different Dual G4 450 MHz running Mac OS X 10.1.5 but got an identical error.




Suggestions welcome, or confirmation to give up hope also appreciated but not quite so welcome. :-}



Share this post

Link to post
Share on other sites

Dude, the data in the Backup Set is bad... I've been there. The data was not written properly to the drive and thus is not useable. There have been a few posts here in the Forum about this, more specifically though about the Adaptec 39160 SCSI card causing the data to be incorrectly written to the device. Sorry... it is bad news... I experienced this and it really upset me.

Share this post

Link to post
Share on other sites

Oh - just to clarify - it is that specific piece of data that is bad, not all the data. Some can still be recovered, just not all of it. Ugh, let's see, what is the most important part of a backup... reliability!!??

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this