Jump to content
Sign in to follow this  
kolohe280

Can't add more storage to a backup set

Recommended Posts

I have a NAS with 2 RAID5 arrays.  I backup to one of them on a share called Online_Backup.  I wanted to add some more space to that backup set, so I created a second share on the other RAID array and called it Online_Backup_2.  When I tried to add the second member to the backup set, it went through the entire dialog (it was able to see how much space is available on that array), and when I clicked OK I got an error "The disk is not accessible".  However, if I create a new backup set and point it to the new share, everything works fine.

I have had no problem creating multiple member storage groups on USB drives.

Ideas?

Share this post


Link to post
Share on other sites

kolohe280,

I see you joined the Forums in November 2012, although this is your first post.  Is it possible you are still running Retrospect Windows 8, or even Retrospect Mac 10—in which case you should have posted to the Retrospect Mac 9+ Forum?  Please post what version of Retrospect you are running, and under what version of your "backup server" machine's OS.  Nobody on these Forums works for Retrospect "Inc.", so we're not going to push you to upgrade to the latest version unless it turns out you need it.  Also please state any error message number you get with "The disk is not accessible".

The reason I ask that is there have been several fixes to the "backup server" Engine for NAS shares since 2014.  If you do a browser Find for "share" (without the quote-marks) on the Retrospect Windows cumulative Release Notes, you'll see them one by one in reverse chronological order.

Have you added the second share on your other RAID array to My Network Places per page 421 of the Retrospect Windows 16 User's Guide (don't worry, the contents of the UGs—other than the "What's New" chapter—hasn't been updated for about the last 5 years)?  Also, did you select the first and second volume using Control-Click per page 419 of  the UG?  Full disclosure: I'm a Retrospect Mac administrator without a Windows machine, so I'm "going from the book" in this paragraph.  Also, try the Repair Catalog procedure as described on pages 451-453 of the UG.

Share this post


Link to post
Share on other sites

Well, duh.  I should have mentioned all of that.  Sorry.

I am not running an ancient version of Retrospect - in fact I am running 16.6 on Windows 10 Pro.

I did take a look at the volumes database and cleaned it up since it seems that the failures with trying to connect to the new backup target left some clutter in there.  That, however, did not solve the problem.  Regarding the not accessible message - no error code - it's in a popup.  However, the operations log does show a message "TVol::Set: no volume name" which makes me think that the volume isn't accessible because the particular piece of code that adds members to existing backup sets neglected to pass that information to the piece of code that actually sets it up.  It only seems to happen with UNC specified volumes.  I can add local disks all day and no problems.

Right now, I'm thinking that this is yet another bug that was added when 16.0 came out.  I've got two tickets open for serious problems with the storage group feature that have been open since March!  They've admitted that one is a major design flaw, and they were working with me on the other problem for a while and then stopped just saying that it had been sent to Engineering.

My confidence in the product is pretty low right now.  I've had to do a crazy number of catalog rebuilds on the NAS backup set since 16.0 came out due to crashes.  And, if they fix the 16.0 problems in 17.0, I'll get to pay for the fixes!!

Share this post


Link to post
Share on other sites

kolohe280,

I deduce from the genesis of your "handle" and your times of posting that you may be located in Hawaii.  Please update your Profile with at least the U. S. state of your Location, so that we may know when to expect posts from you.  Also please add your Gender, so I don't either have to address you in the second person or refer to you as "he/she" (not knowing the Hawaiian language, I have no idea what the gender of a kolohe is presumed to be).

With that housekeeping detail out of the way, were you able to do similar things with NASes successfully in earlier major versions of Retrospect Windows?  I ask because the Retrospect Windows cumulative Release Notes show the engineers added several Engine fixes and improvements to NAS support in the 16.5 releases and and the 16.6.0 release.  In the last two major releases of Retrospect, there is abundant evidence that improvements and fixes to existing features were botched—especially in x.5 and x.6 "minor" releases.  As a lowly paying user with 40 years experience as an applications programmer, I think these botches resulted because the engineers have been really rushing to add major new features—Storage Groups and the Management and (demo) non-Management Consoles.  I therefore suggest, given that Storage Groups IMHO basically eliminate a lot of Backup Set bookkeeping—mostly for Proactive scripts (which I've never used)—that experienced administrators were able to do before with more effort, you consider downgrading to 15.6.1.104 and asking Retrospect Sales for a refund on version 16.

Even if you're not actually willing to go through with that downgrading, IME it will be an excellent bargaining tactic in getting a free upgrade to Retrospect Windows 17.  About two years ago, I stayed on Retrospect Mac 14.1 until Retrospect 15 had been out for over half a year—because of a trio of -530 bugs that Retrospect Mac 14.6 seemed to make worse and for which I filed Support Cases.  Then, after running some inconclusive beta tests with an augmented-logging test version that Tech Support sent me, I paid for Retrospect Mac 15 with the proviso that I get a free upgrade to Retrospect Mac 16 even though I was upgrading a couple of months earlier than the free-upgrade cutoff.  Considering that you report that you have been substantially helpful in diagnosing bugs in the hot new Storage Groups feature, I speculate that you can bargain from Sales (who have access to everybody's Support Cases) the same kind of free update to Retrospect Windows 17—especially if you only license the Desktop Edition as I do.

 

 

 

Share this post


Link to post
Share on other sites

Unless you are the owner of the forum (which I'm pretty sure you're not), please don't take it upon yourself to suggest "housekeeping details" to me.  The "genesis" of my user name is of no concern, nor is my location or when I created a userid on this forum.  And, in today's environment, asking a person for their gender is just plain dangerous.

I opened a ticket with support on this issue.  It was accepted, which surprised me since I'm not paying for maintenance.

Share this post


Link to post
Share on other sites

If kolohe280 had been reading the Forums regularly since they signed up 7 years ago, they would have noticed that I frequently post a link to this.  Surprisingly, its fifth paragraph reads:

Quote

Note that, despite the new dialogs in the Retrospect Inc. Support Case system urging you to sign up for Annual Support and Maintenance, Mayoff has verbally assured me that you don't need to be signed up for ASM to report a bug—only to get personal assistance with coping with it.

Its sixth paragraph suggests that the head of Retrospect Tech Support post a version of what I link to as a "sticky thread".  IMHO he hasn't done this because he wants people to sign up for ASM, which funds his department's budget.  I think such discouragement of administrators from filing Support Cases has been unwise, and that the StorCentric acquisition is partly a result of Retrospect's reputation for bugs not getting fixed—sometimes for years.

They also would have noticed that a fair percentage of reported bugs involve Retrospect incompatibilities with various OS features.  There are several volunteers who are experts in that area, but who can't help administrators who don't say what OS version they are using.  OTOH I am fairly familiar with where to find information on various Retrospect features and updates, but I can't help administrators who don't say what Retrospect version they are using.

Finally they would have noticed that a fair percentage of OPs on these Forums are from non-Americans.  I try to spot these (foreign-sounding user names are one of the clues), so that I can explain any American slang I might use and try to simplify the English I use to respond to such administrators.  Moreover, some of the most knowledgeable volunteer responders on these Forums are British or Scandinavian—and are proud of it.

Share this post


Link to post
Share on other sites
On 12/22/2019 at 11:25 PM, kolohe280 said:

I have a NAS with 2 RAID5 arrays.  I backup to one of them on a share called Online_Backup.  I wanted to add some more space to that backup set, so I created a second share on the other RAID array and called it Online_Backup_2.

Crazy suggestion -- try naming the new share "2nd_Online_Backup" instead, and see if that solves it.

Reason being, different implementations of SAMBA have different lengths of "valid" names, and using the same first-13 characters in each may be confusing something (eg if it only parsed the first 8 characters).

Otherwise, knowing your NAS make/model might help.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×