Jump to content

Client no longer shows External Drives as available

Recommended Posts

My Retrospect Client suddenly refuses to give access to the External Drives

It says they are offline ... these drives are not*, the Mac OSX High Sierra system is fine using them for all other activities.

Server Was connecting to this client previously [6 days ago] 100% OK and backups from external drives worked fine.
Only now Retrospect Client? refuses to allow access now and reports them offline.
They are 

 OSX High Sierra Retrospect Client

OSX Catalina Retrospect Server

Latest version of Retrospect 16.5.x




Share this post

Link to post
Share on other sites

I'm curious why you have installed the Retrospect server app on the client FS SERVER. I wonder whether this could be part of the problem; say, if the external volumes on that machine have been reserved for a local backup.

Should we assume that there's no problem that the local volumes JRP DATA and JRP DATA BU are shown as offline?



Share this post

Link to post
Share on other sites

For the last many months this has worked perfectly.

Yes, both sites have the same version of Retrospect Server 16.5.1

What I call the CLIENT site also has Retrospect Client installed.

The SERVER Site backs up over Retrospect Remote Backup just one folder on the CLIENT site.

Like I say, this has worked perfectly until 6 days ago.

It is not an issue of whether a Server backs up a Server licensing as it has worked this way for months AOK.


JRP DATA and JRP DATA BU are removable drives that are stored offsite FYI 🙂


Share this post

Link to post
Share on other sites


Have you read the "Catalina" sub-section under the "Technical  details" section in this Knowledge Base article?  Although it's termed a "folder"—which I think is sloppy editing by the engineer who copied the article for Mojave and updated it for Catalina, it sounds as if your external drives  must be given "Full Disk Access" in System Preferences->Security & Privacy->Privacy.  And the last sentence under "Version 16.5 Required" in this KB article requires Full Disk Access for "...  removable volumes and network volumes."

Share this post

Link to post
Share on other sites
On 11/26/2019 at 4:14 PM, redleader said:

It says they are offline ... these drives are not*

It says they are offline to the Retrospect client of FS Server (which is different from offline to FS Server's OS).

As David says, check FS Server's Privacy settings and make sure Client has Full Disk Access. You could also get clever in the Terminal with "lsof" to see if any process is blocking access to those volumes, but I'd start with restart of FS Server to clear everything and turn to Terminal if the problem came back.

Are you actually using FS Server as a RS backup server? If not, stop the Retrospect Engine via its Preference pane -- the Engine *shouldn't* interfere with the Client's access to those volumes, but if you don't need it why take the chance?

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now