Jump to content
roobieroo

Scanning Synology is slow compared to QNAP

Recommended Posts

I have two client sites that I use Retrospect with and back up a QNAP at one and a Synology at the other. Retrospect is 16.5.1. Performing the initial scan of the QNAP is very fast and it will scan about 5TB's of data of 1.2 million files in 15 minutes while the Synology takes about 1.5 hours to scan just 1.5TB's of data of 850,000 files. Both locations have the same Mac Mini running Mac OS 10.14. The QNAP backup machine also has more RAM but according to the Activity Monitor, memory is not an issue on the slower Synology machine. Performing file copies from the Synology to the machine running Retrospect is very fast and in line with what I would expect to see. Scanning machines that have the Retrospect client installed is very fast. It doesn't matter if I add the share via AFP or SMB although I have had Retrospect get stuck scanning when using AFP which could be related. When the actual backup finally does get around to happening it copies larger files as expected but smaller files like the .ds_store files is really slow. That part I'm not so worried about, it's the long scanning time that concerns me.

I even took a clone of the backup server from the fast location over to the slow server and it backed up just as slowly. It also hung Retrospect when trying to scan when connected via AFP. 

One thing I did notice is that the Synology shows up as Mac OS Appleshare next to the File System entry but the Synology says Unknown. 

Can any of you think of some settings that could be causing such slow scan times for the Synology share? It does have a second Synology that mirrors its data and uses Backblaze for cloud backups but looking at the performance monitor of the unit during scanning shows nothing using a ton of resources. Is the slow scan time something that is normal with Synology NAS boxes? 

Share this post


Link to post
Share on other sites

The Synology is a DS918+  with four Seagate ST4000VN008-2DR166's configured as a RAID 5. It's set up for high availably mode with a duplicate DS918+. The file system is Btrfs which now that I've done more digging looks like it could the cause of the difference. It's connected to a gigabit switch on both network interfaces. 

The QNAP is a TVS-EC1080 with eight Western Digital WD30EFRX-68EUZN0's configured as a RAID 5. The file system is Ext4. It's connected to a gigabit switch with four ethernet ports configured for balanced mode. 

QNAP even has a marketing page about why they don't use Btrfs and one of the bullet points is that it's slower, especially for high I/O operations. https://www.qnap.com/solution/qnap-ext4/en/

Share this post


Link to post
Share on other sites

Seems likely you hit the nail on the head.

Just for fun, what happens to times if you run a second backup of the Synology on the same day? I don't know if an RS scan would be considered "file access", but it's possible that you are triggering a metadata update across all the files (see here) which is slowing things down.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×