Jump to content
Sign in to follow this  
zz-pdb

multicast on wrong interface

Recommended Posts

I have a Linux (Ubuntu 18.04 LTS) system that has two network interfaces, and its doing its multicast advertising on the wrong one. Is there no config file or anything for the Linux client so that i can change the interface or even just have it not advertise?

Share this post


Link to post
Share on other sites

zz-pdb,

Both possible versions of your problem have been discussed in a Mac 9+ Forums thread.  Here's my post that distinguishes both versions; you can look forward or backward in that thread to find a possible solution for your particular version.

However if it is indeed your "client" machine that has two network interfaces, this Knowledge Base article doesn't say how to specify the "ipsave" command for the Linux Client software.  Page 554 of the Retrospect Windows 16 User's Guide says:

Quote

Note:In addition to the Java-based graphical user interface, Linux clients can also be controlled through the command line. To see the command line arguments, enter the following:$retrocpl --help

If that doesn't help, here's why and how to submit a Support Request for a bug.

P.S.: I had forgotten to suggest that you Add Source Directly, specifying its fixed IP address on your LAN.  I see that this option in adding "client" machines, which solved  a two-year-old problem I had with -530 errors, is called Direct Access Method on pages 294 and 296-297 of the Retrospect Windows UG.  Since Subnet Broadcast—which also to some extent bypasses Multicast—may solve your problem if it is your "backup server" that has two network interfaces, you probably should read pages 294-299 in the UG.  Either way you'll need to Remove and re-Add your "client" machine.

Edited by DavidHertzberg
P.S. saying Add Source Directly, called Direct Access Method in Retrospect Windows, is an option—as is Subnet Broadcast

Share this post


Link to post
Share on other sites
On 6/17/2019 at 7:42 PM, zz-pdb said:

I have a Linux (Ubuntu 18.04 LTS) system that has two network interfaces, and its doing its multicast advertising on the wrong one.

Retrospect Client binds to the first available interface -- Client queries the OS for active interfaces, OS responds with an array of those available, Client binds to first item in the array. That suggests three possible approaches:

  1. If one interface *always* comes up before the other, re-do your network settings so that one is on the Retrospect subnet. This will stuff up any other software that also only binds to "first available" but you want on the *other* interface
  2. If interface order can vary you'll have to get creative with your machine's startup scripts -- basically you're looking to get the interface you *don't* want Retrospect to use to come up after Retrospect has been initialised. Again, this could stuff up other software
  3. You might be able to do it later by taking down the interface you don't want to use, stopping and starting RetroClient (so "retrocpl --stop" then "rcl start" -- turning the client off and on will not do the job), then restarting the "unwanted" interface.

Unfortunately the Linux client has nothing equivalent to the "ip" and "ipsave" commands available on Mac and Windows.

There may be other ways round this, depending on your network setup, but I'm afraid I'm no Linux guru...

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×