Jump to content
Indi-Tech

Favorites becoming "unfavored" (error -1101) for no reason

Recommended Posts

I've had a working setup that stopped recognizing the favorites I set. I had to manually "browse" each favorite to make Retrospect honor them again. Nothing occurred to the client or server that should have caused this. No updates, crashes––nothing.

Latest version of Retrospect, client and server. Mojave 10.14.4 on the client and latest El Cap on the server.

Before browsing.

942628420_ScreenShot2019-05-21at11_09_33AM.png.177c634ee1c5a2dafefcb0446fff2458.png

After browsing.

78061691_ScreenShot2019-05-21at11_10_29AM.png.7ef1685f6f82c1d1d6ded78f7ca7ac99.png

Screen Shot 2019-05-21 at 11.08.57 AM.png

Share this post


Link to post
Share on other sites

Indi-Tech,

First, I think you got a bit too cute with your screenshots.  Favorite Folders belong to drives, but you edited-out the parent drive(s)with its/their disclosure triangle—although I think I see the ghost of one at the very top of your topmost "After browsing" screenshot.  Also, assuming these are screenshots of the Sources panel, you appear to have re-arranged the columns so that the relevant ones would appear within the width of a Web-browser window.

Second, I did a Forums search; the only recent part-of-a-thread that seems relevant starts with this post.  Although I've been using Retrospect Mac for 19 out of the last 24 years, I only started using a Favorite Folder about 6 months ago.  But that Favorite Folder, with which I've had no trouble, is on a HDD that is locally attached to my "backup server"—whereas you state that that these Favorite Folders are on drive(s) on a "client" machine.

Based on what henry-in-florida said a couple of posts above the post linked-to in the preceding paragraph, I'm now going to make a wild-a**ed guess that your problem is somewhat similar to the problems I had for two years with -530 Client Not Found errors—and that these Favorite Folders are the on the first "client" backed up in one or more of your scripts.  The short  version of my cure would be to Remove the "client" in Sources and re-Add it with Add Source Directlynot Use Multicast.  Before doing this you'll have to make sure that the "client" has a fixed IP address on your LAN; after doing this you'll have to re-checkmark that "client" and its Favorite Folders in each of your applicable Scripts, dragging the "client" in the Summary list pane of each Script in order to get it into the desired backup sequence.

I actually got the clue for the cure for my -530 errors from something henry-in-florida wrote.  The explanation I eventually came up with for my -530 problems is described in the last quote and the two sentences following it in this post in another thread.  The symptoms you describe for your -1101 errors sound similar to my Phase I -530 situation starting in February 2017.  My first cure, which worked until November 2017, was to schedule a "sacrificial" script 5 minutes before each "real" backup script, in which only the first "client" was specified and in which the No Files Rule was used.  My assumption, based on a suggestion made by a networking expert on the Ars Technica forums, was that my -530 errors were caused by a timing error during startup of the "backup server" Engine—since I was only getting -530 errors if I didn't boot my "client" and "backup server" machines until at least 10 minutes after the "real" script's scheduled start time.  After this stopped working in November 2017, I found that I could avoid problems by pausing all scripts, clicking  the "backup server" Locate button for my first "client", and then killing the "sacrificial" script.  That sounds rather like what you are doing to temporarily avoid -1101 errors.

Here is how and why to submit a Support Case.  You'll notice that Retrospect Inc. personnel no longer look at the Forums, even the "Retrospect bug reports" one.  The Retrospect Inc. engineers did try to find the cause of my -530 bug in May 2018—many months after I submitted a Support Case, but their test version of the Engine and Console didn't fix it.  My guess is, as reflected in the first quote in this same post in another thread, is that Use Multicast—which once worked beautifully in Retrospect—is now inhibited by features added to some home networking equipment.  The engineers in Walnut Creek CA  simply don't have the equipment to reproduce the problem, so they have tried to find it from logs etc. they requested I submit.

P.S.: henry-in-florida reported that Adding with Subnet Broadcast worked for him, and he didn't need to Add Source Directly; I tried it briefly last year and it solved my -530 problem.  If I'm reading page 79 of the Retrospect Mac 16 User's Guide correctly, Subnet Broadcast doesn't use the now-troubled Multicast feature.  Like Use Multicast it allows a backup administrator without IT training to add additional "clients", but only after an IT-trained person—IMHO one with even more knowledge than is required to set up fixed IP addresses—has set up Retrospect.

P.P.S.: Indi-Tech, if you're going to us these Forums for help you should check recent threads before starting a new one.  twickland reported the same problem with Favorite Folders less than a month ago; for some reason his post didn't show up on my Forums search.  He was using Retrospect Mac 16.0.1; does your "Latest version of Retrospect" mean that same version?  There is now a 16.1.1.100, BTW.

Edited by DavidHertzberg
Added P.S. about Subnet Broadcast; added P.P.S. about Twickland's thread and his version; in first sentence of 2nd paragraph, linked to later post in same thread

Share this post


Link to post
Share on other sites

For what it’s worth, I’ve seen this for a couple of years. Favorites on external drives are not seen by Retrospect after a reboot of the client in many cases. I don’t know if this is related to Mac OS changes or Retrospect changes. My workaround has been to use selection criteria instead, which isn’t great. 😞

Share this post


Link to post
Share on other sites

AntonRang,

You don't say what version of Retrospect you are running, and under what version of macOS you're running it.

The latest version of Retrospect Mac, released on 28 May, has the following fix in the cumulative Release Notes:

Quote

Engine Fixed NAS: Fixed issue where certain NAS devices could no longer be found (#8121)

If that doesn't help, here's why and how to file a Support Case for this bug.

Share this post


Link to post
Share on other sites
On 6/20/2019 at 1:14 PM, DavidHertzberg said:

AntonRang,

You don't say what version of Retrospect you are running, and under what version of macOS you're running it.

The latest version of Retrospect Mac, released on 28 May, has the following fix in the cumulative Release Notes:

If that doesn't help, here's why and how to file a Support Case for this bug.

Latest versions. Been working with Retrospect support on a few issues, this being one. No solutions so far. Thinking our setup with multiple VLANS and IPs/NICs isn't ideal for Retrospect, at least at the moment.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×