Jump to content
Sign in to follow this  
francisbrand

Dashboard Backup Report Errors

Recommended Posts

Hi,

 

I have a single server plus client setup runing on 15.6.1. Whenever I look at the Backup Report Pie chart I think that I've got loads of failed backups unprotected clients as a number of clients are appearing in the grey section. However if I look at these clients in the "Past Backups" I can see they have run successfully. This isn't for all clients. Any ideas?

 

Thanks,

 

Francis

Edited by francisbrand
Incorrect description of issue.

Share this post


Link to post
Share on other sites

francisbrand,

Now that I've been forced to upgrade to Retrospect Mac 15.6.1.105, I'm seeing the same problem.  However, in addition to missing drive backups for one "client" in the Backup Report pie chart, I'm seeing the same missing drive backups for one "client" in the Backups bar chart.  I should note that that particular "client" is only backed up as a Recycle once a week, and that—as part of the switching-between-Retrospect-versions described in this post about "Deferred" testing—I ran that particular "client"'s Recycle backup twice in three days using the same Catalog.  That may explain why my Dashboard problem is worse than yours.

Therefore I'm not going to submit a Support Case on this problem.  But I think you should; here's why and how.

IME the Backups bar chart has been buggy for years.  The data that is showing spurious unprotected clients in the new Backup Report pie chart may be drawn from the same, presumably Engine, data.  After ignoring that problem for years, the increased prominence of the Backup Report may force the Retrospect Inc. engineers to fix it.  My heart bleeds for them. ;)

P.S.: As of Sunday 20 January I had been running 15.6.1.105 for over a week, including another "Sat. Backup" script run Recycling 6-plus-a-Favorite-Folder drives twice on Saturdays.  I've seen comparable Dashboard bugs for the latest "Sat. Backup" script run, including omitting the first "client" from the Backups bar chart (that "client" is shown on the daily Backups bar charts for "Sun.-Fri. Backup" No Media Action script runs the other days of the week) and saying all 3 drives from the other "client" (which is only backed up on Saturdays using the Legacy Client) are Unprotected on the Backup Report pie chart.  Therefore I have now submitted a Support Case.

Edited by DavidHertzberg
Added P.S.

Share this post


Link to post
Share on other sites

(Copied—with clarifications—from the latest Additional Note to my Support Case) Interesting results running my "Sun.-Fri Backup" scripts early this morning, which is a Sunday:

I initially looked at my Mac Pro "backup server" in the bedroom just after the "sacrificial script" (see last substantial paragraph of this post for the initial explanation of what that means) had started running. The Dashboard's "Most Recent" pane showed all 7 drives backed up—in a Recycle—as of yesterday. The "Backups" bar graph for yesterday did show a segment on the right end for my Macbook Pro's "Macintosh HD", and the circular "Backup Report" showed all 3 drives on the G4 as Unprotected. The "Backups" bar graph showed segments for the preceding Sunday-Friday "Sun.-Fri. Backup" daily No Media Action script runs, which backup only my MacBook Pro.

I again looked at my Mac Pro "backup server" just after the "real script" had finished running. In the "Backups" bar graph for yesterday the backup for the Favorite Folder had changed, now being shown in two segments. The first segment is all the way on the right, in place of the backup for my MacBook Pro's "Macintosh HD"—which is the first drive backed up by the "Sat. Backup" script. The second segment is all the way on the left, which is where it should be because the Favorite Folder is backed up last by the script. I had not restarted the Console while all this was going on, so the change must have been from the Console picking up revised information from the Engine.

The circular "Backup Report" still showed all 3 drives on the G4 as Unprotected. Since the circular Backup Report is new in version 15, my guess is that the engineer who programmed it said to himself/herself "I know that version 16 is not going to handle Legacy Client machines, so I won't bother to provide for them in the circular 'Backup Report'".

Edited by DavidHertzberg
Clarifications in first substantial prgf.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×