Jump to content

Files missing from Snapshot after Transfer Snapshots

Recommended Posts

I've just transferred most recent snapshots from a 100+ GB backup Disk Backup Set to a Cloud Backup Set (backblaze)

I had to restart half way through - it suddenly bailed out with:

        [*] TBackblazeConn::b2_upload_file: Request Error: error -1010 (API request bad) ()
        [*] DS3::ds3CloseFile: cannot write to AC000025.rdb: error -1010 (API request bad), resetting m_pos from 3,993,600 to 3,840,000
        [*] xopFlush: flush failed, error -1010 (API request bad)
        [*] xopFlush: flush failed, error -1010 (API request bad)

I restarted the Transfer, and the remaining files copied across. ?

However, when I do "Find Files" on the resulting backups, the number of files is different, and the cloud set is 900 MB smaller. So it seems some files are missing. But if I re-run Transfer Snapshots, it completes instantly, saying that there is nothing to copy. Retrospect thinks nothing is missing. I tried recreating the catalog, but that didn't help.

By using selectors, I've managed to track down a whole folder that's missing - except that it's not missing if I start with "Restore" instead. So I've found what's happened - the files are there, but they are not included in the snapshot. The snapshot file must have failed to transfer.

So my question is: How can I ask Retrospect to copy across the Snapshots again, so that I get a complete set of Snapshots - but without having to recycle and re-upload all 100 GB. The other reason to avoid this drastic restart is that, going forwards, something similar could recur, and then recycling would lose older snapshots as well as resetting the most recent one I'm trying to get right.

Retrospect 12.6. Windows 10 x64

Share this post

Link to post
Share on other sites

Try doing a thorough rebuild of the catalog for the cloud backup set. To effect a thorough rebuild you will first need to delete all the *.SESSION files that are in the folder(s) that hold the *.RDB files for the backup set. Once the *.SESSION files are deleted rebuild the catalog. A thorough rebuild of the source backup set may also be advisable just in case an error their cause the initial snapshot transfer failure.

Because Retrospect is now reading the file information from the .RDB files instead of the .SESSION files, and depending on the connection speed to the cloud provider, the rebuild could take some time to complete.

Hopefully after the thorough rebuilds a rerun of the transfer snapshot should pickup the missing files.

Share this post

Link to post
Share on other sites


I tried that. It took a while (of course, lots to download) and the log said it was doing a "thorough" rebuild as required.

After doing that, I did another "Transfer Snapshots", with the same parameters as before. The job ended quickly, with nothing to transfer. Only, now I've rebuilt the catalog thoroughly, the difference in the two sets is not 900 MB but more like 10 GB. The same directory I had identified as missing is still missing. Again, I can get that directory if I use the "Restore" function instead of "Find Files", which must again mean that the files are backed up but are just absent from the snapshot.

Does anyone have any further thoughts or suggestions?

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now