Jump to content
lstone19

Server keeps changing client address

Recommended Posts

For the last week or so, the Retrospect server keeps changing the address of one of my clients from its assigned internal address (192.168.0.70) to an address in the self-assign range (169.254.120.108). This seems to be happening daily. This is after years of this client working just fine. It's just this one client (two other Macintosh clients and a Windows client work fine - OTOH, both other Mac clients, despite having pushed the v15 client update to them, say they're still running 14.5.0.146 but that's a separate issue that I see has been brought up in another topic).

My fix is to re-add the client via "Add Source Directly ..." (it shows up in the Add box (with "Use multicast") but the Add box stays dim) with the correct IP address which corrects if for awhile (usually long enough to run backups) but then a few hours later goes back to the 169.254.120.108 address).

Any ideas? My thought is that since the other clients still claim to be on 14.5.0.146 and aren't having this issue is that it's related to the 15.1.0.131 client but that's just speculation.

Retrospect server version: 15.1.2
Client version: 15.1.0.131

Share this post


Link to post
Share on other sites

I've managed to deal with it (but still don't know why it's happening) by checking the "Ignore client discovery" checkbox on the Options screen of where this system is listed as a Source on the Retrospect Server. Ignore client discovery appears to be a new feature added three years ago in 12.0.0 whose only documentation I can find is a line in the Release Notes:

Network

  • New "Ignore client discovery" checkbox for preserving Client's address in certain firewall and NAT environments

I have now noticed that on the client, on the Retrospect Client system preference screen, it's sometimes showing an address in the self-assigned range (169.254.x.x) as its address rather than the correct one, even as all networking functions on this client system continue to work normally so no idea where it's getting that self-assigned address.

At one point over the weekend, I tried falling the client back to 14.6.0 (I tried to download 14.5.0, the version of the client the other Mac clients are running, from the Retrospect website but it throws an error) but had the same issue. So my speculation in the original post that it's related to the 15.1.0 client appears to be unfounded.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×