Jump to content

Recommended Posts

I have Retrospect for Windows 12.6.1.101 Desktop with Dissimilar Hardware Restore.  Up to now, I have been backing up the computer running Desktop and two clients to four hard disks, in rotation. 

Now I have gotten a new machine and want to restore the operating system and data files from one of the old machines to the new machine.  The old machine has a 1 TB SSD, partitioned with two volumes, one for the operating system and one for data, plus, of course, the UEFI system and the recovery partitions.  The new machine has two SSDs:  1 TB for data (replacing the OEM hard disk) and 512 GB for the operating system (replacing the OEM SSD).  The 1 TB SSD currently has the original operating system on it (copied from the OEM SSD by Samsung migration software).  The 512 GB SSD is empty, except for being partitioned and formatted.  The UEFI system and the recovery partitions were copied from the 1 TB SSD.  I've been having trouble restoring the operating system volume to the 512 GB SSD using the Disaster Recovery client.  I have installed the driver for that SSD into the DR client.  The otherone does not need a special driver.  The most recent error I've gotten is

+    Executing Restore from Backup at 2/1/2018 3:10 PM
    2/1/2018 3:10:42 PM: Connected to minint-d36kkvn
    To volume Programs Disk (C:) on minint-d36kkvn...

-    2/1/2018 3:10:42 PM: Restoring from Backup Set 1, Snapshot Dell15R, 2/1/2018 4:43:44 AM
        [*] T-29: VssWBeginRestore: PreRestore failed, winerr -2147212270, error -3045
    2/1/2018 3:11:16 PM: Execution incomplete
        Duration: 00:00:09 (00:00:03 idle/loading/preparing)

I got other errors before this, the most significant being Retrospect telling me that it was going to wipe out information on the other SSD, not the one I told it to restore to.  To stop it from saying that, I first changed the drive letter on the volume I didn't want Retrospect to write to and, when that didn't work, I took the volume offline.  Then I tried taking the whole disk offline.  Still no joy.

So now I am at a loss.  I know that, as a last resort, I can reinstall the operating system, but why should I have to?  I hope that, if I do that, Retrospect will at least let me restore the data.

 

.

Share this post


Link to post
Share on other sites

rfajman:

You should look at this 2014 Knowledge Base article.  To my intense surprise (insert appropriate smiley here) its title is "Error -3045 (There is insufficient storage space to complete the operation) and -3405 (Cant backup system state)".  It sounds to me as if Retrospect thinks the 512GB SSD on your new machine is too small to restore the partition on the old machine that contains the operating system.  Do consider the first and last paragraphs in the article, concerning extra space that will apparently be required on your 512GB SSD.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×