Jump to content
johndon

Catalog Files on a NAS

Recommended Posts

On previous computers I used to keep my Retrospect catalog files on a NAS winch I mounted as a network drive (Drive X:\).  I can no longer do this on my new Windows 10 computer with Retrospect 11.5.0.190.  When I go to Backup Set Selection--More the mounted network drive no longer shows up. What do I do to get Backup Set Selection see my X Drive? 

Share this post


Link to post
Share on other sites

I don't think this is a Retrospect issue because I've seen it happen with other applications in similar situations. Microsoft has somehow screwed up the ability to browse a network and look for shares.

 

I would first focus on finding out whether the Homegroup feature is enabled in the Network control panel.  Disable it and go back to conventional network sharing.  There is plenty of information you can Google on this subject.

 

Good luck.

Share this post


Link to post
Share on other sites

I have found the most reliable way to access my Retrospect (and other applications') files on a NAS with Windows 10 is to use the UNC path (i.e. \\NAS-name\share-name\). Even if Windows 10 cannot 'see' the NAS as being present when trying to browse the network you can still enter the UNC path to the files you want in the Windows Explorer location bar to access them.

If you can view the Catalog file for the Backup Set in Windows Explorer then a double-click on the Catalog file should open it in Retrospect.

It could also be possible that your NAS only supports the SMB1 protocol. Microsoft is in the process of disabling support for SMB1 in Windows 10. (Various factors govern whether SMB1 is enabled or disabled.) If your NAS supports SMB2 or later this should not be a problem.

Share this post


Link to post
Share on other sites

I'm hitting similar problems with Windows 10 occasionally losing the ability to discover the NAS boxes on my home network, a situation that is currently preventing one of my automated backup jobs from running (though it works fine if I open Retrospect manually before the job is due to start). Rather oddly, several other automated backup jobs that use the same NAS (though not the same destination folder) continue to run fine. I've just upgraded to V12.5, but it made no difference.

However, I have not yet found a way in Retrospect to specify the backup destination using the UNC path. I would appreciate some guidance on this point.

Share this post


Link to post
Share on other sites

You can set the path to the members of the Backupset as follows:

  1. Open the Backupset 'Properties' dialog
  2. Select the 'Members' tab
  3. Select the member you want to update then press the 'Properties' button
  4. In the 'Location for backup data folder:' field enter the UNC path in the format \\NAS-NAME\share-name\
  5. Press 'OK' to save the new path

The above directions assume that the 'Retrospect' folder which contains the Backupsets is not in a sub-folder of the NAS share.

A reliable workaround I use for Windows Explorer not being able to find my NAS automatically is to add and pin a link to the 'Quick access' list in the left panel of Windows Explorer.

Share this post


Link to post
Share on other sites

Haggis999 has now been a victim of one of the many foul-ups in recent editions of the Retrospect Windows User's Guide.  When DovidBenAvraham and I researched it for the old version of the Wikipedia article, the only mention of the WebDAV protocol for cloud backup (still supported in the latest version of Retrospect, although AFAIK AWS-S3-compatible cloud backup was added in Retrospect Windows 11 because almost nobody supported WebDAV) was in a Release Note for Retrospect Windows 8.  That Release Note mentions UNC, but refers to “To add a network volume to the volumes database” which has never been on the page where the Release Note says it is.  It is actually under "My Network Places" on page 441 of the Retrospect Windows 12 UG.

It gives a different procedure than Scillonian has posted above, which may be because it is for setting up a Volume instead of a Backup Set, and says in step 4 "You can also click Advanced to specify a UNC path to the volume you want to add."  That's the only place, other than the Release Note, where UNC is mentioned in the UG.  The procedure Scillonian shows may have recently been added to Retrospect Windows.

Edited by DavidHertzberg
Bolded Scillonian's name in first sentence of second prgf.

Share this post


Link to post
Share on other sites

I've just checked the member properties as Scillonian advised and found that the location is already in UNC format (\\PRIMARYNAS\Backup\). However, the job in question actually saves the backup in \\PRIMARYNAS\Backup\My Pictures. You suggest that this might be a problem, but the job has been running successfully for many years. It's only become an issue since Windows 10 decided to forget my NAS boxes.

I already have my primary NAS listed under Quick access. That's useful in Windows Explorer, but doesn't help Retrospect find the NAS when running an automated job using the Retrospect Launcher.

Share this post


Link to post
Share on other sites
1 hour ago, haggis999 said:

I've just checked the member properties as Scillonian advised and found that the location is already in UNC format (\\PRIMARYNAS\Backup\). However, the job in question actually saves the backup in \\PRIMARYNAS\Backup\My Pictures. You suggest that this might be a problem, but the job has been running successfully for many years. It's only become an issue since Windows 10 decided to forget my NAS boxes.

....

It sounds to me as if haggis999 should define \My Pictures as a Subvolume on \\PRIMARYNAS\Backup.  The procedure to do that starts under "Subvolumes" on page 444 of the Retrospect Windows 12 User's Guide.  Since that is only 3 pages after the procedure I mentioned in this post (gosh, how I miss the post #s that used to be in the old IPS Community version of the Forums software), I imagine creating a Subvolume is a variant on that procedure.  haggis999 should then change his/her script to put the Subvolume into the Backup Set.

As an experiment a few months ago, I created a Favorite Folder (the Retrospect Mac name for Subvolume) on a local drive, and ran a script backing it up.  However I have never tried using a Favorite Folder as a Destination for a backup, although I understand from the Retrospect Mac 14 UG that it can be done.

Share this post


Link to post
Share on other sites

On second thought this smells like an account permissions problem (I only administrate a home LAN without any inter-person security complications), given that haggis999 reports in this post that he/she can run the problematic script manually and run other scripts that backup to the same drive.  IMHO haggis999 should read this Knowledge Base article again, paying special attention to the numbered items at the start of the article and to the "Retrospect 6.5 and Later" section at the end of the article.  The Retrospect Windows 12 equivalent to the procedures in that section starts on page 419 of the UG, headed "Run Retrospect as...".  Haggis999 may have to recreate the problematic script logged-in under an account that corresponds to the account for the Subvolume. 

Edited by DavidHertzberg
Bolded haggis999's name in one more place, italicized "again"

Share this post


Link to post
Share on other sites
18 hours ago, DavidHertzberg said:

On second thought this smells like an account permissions problem (I only administrate a home LAN without any inter-person security complications), given that haggis999 reports in this post that he/she can run the problematic script manually and run other scripts that backup to the same drive.  IMHO haggis999 should read this Knowledge Base article again, paying special attention to the numbered items at the start of the article and to the "Retrospect 6.5 and Later" section at the end of the article.  The Retrospect Windows 12 equivalent to the procedures in that section starts on page 419 of the UG, headed "Run Retrospect as...".  Haggis999 may have to recreate the problematic script logged-in under an account that corresponds to the account for the Subvolume. 

Thanks for persevering with this, David. I will do as you suggest and check out that KB article more carefully over the coming weekend.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×