Jump to content
Sign in to follow this  
pls2000

Can't download 11.5 update

Recommended Posts

I'm running Retrospect Professional11.0.1.106 on a Windows 10 x64 system. Two weeks ago I got the 10 Anniversary Update. 

 

Today I did a manual check for updates in Retrospect and found an update to 11.5. I selected to install this, it went through downloading, then nothing happened and I still had 11.0. 

 

I tried downloading the update into my directory. It went through downloading. I could see the temp file being downloaded. But when the download finished, the temp file vanished and no update existed. I've tried this with a couple of locations, getting the same result.

 

No what? Is there a way to get the update other than by downloading in Retrospect? If I download the full version, will my installed license work?

 

  Thanks,

    ++PLS

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×