Jump to content

Deleted script still tries to run.

Recommended Posts

Hi all,


I had a script that was running to do offsite backups w/ version 12.5. We've switched to a different solution for offsite backups and thus don't need the script anymore.  I removed the script from Retrospect without issue, but the script still tries to run at the scheduled time. Of course now that it's media set isn't there anymore it freaks out and sends me somewhere in the neighbourhood of 12 emails a night.  I'd like to get this resolved.


I tried deleting the catalog file in /Library/Application Support/Retrospect 

but that hasn't made any difference. 


Any ideas on where the reference to run this script is located?  

Share this post

Link to post
Share on other sites

Under "Activities" and then "Scheduled", you should be able to see and edit (remove) the schedule.



Thanks for the reply.


That only shows me my expected nightly onsite backup, not the offsite backup that is trying to run.


Share this post

Link to post
Share on other sites

With all you have tried, it sounds like the likely culprit is a corrupt configuration file, Config80.dat, located at /Library/Application Support/Retrospect. You can test this by quitting the Retrospect console app, stopping Retrospect engine, dragging both Config80.dat and Config80.bak to the desktop, and restarting the engine/relaunching the console.


If your problem has now gone away, you can confirm that your original Config.80 is the source of the trouble by replacing the new Config.80 with the original file and seeing if the problem comes back.


Unfortunately, if Config.80 is corrupt and you don't have a good backup of that file, you will need to recreate all your scripts, lists, custom rules, etc. from scratch. (Many of us have long wished that Retrospect housed all of these items in separate files so that corruption in one area didn't ruin everything.)

Share this post

Link to post
Share on other sites

You might want to try to create a new script with the same name as the one you are having problems with. Hopefully it will overwrite the problematic one. Maybe you should also add a schedule to the script, save and then delete the schedule.

Finally just delete the newly created script.

  • Like 1

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now