Jump to content
Sign in to follow this  

Styling buttons for Retro forums posting missing under Firefox

Recommended Posts

About two weeks ago I created a new topic here about the use of word styling and “smilies” on the Retrospect Forums. By experimentation I had found out that I could get italic into posts here by using the before-and-after "tags" (not to be confused with Forums tags) that work in the forums on another website. However those forums have buttons beside and above the posting pane that put in the styling "tags" before and after a selected word or phrase, and that put in a specified "smilie" wherever the cursor is.


On a whim (it was a Sunday evening) I drafted a post on the other forums by clicking all of its "smilie" buttons, copied and pasted that draft into a post on this forum, and deleted the draft on the other forum. On this forum a number of the "smilies" in the post generated the intended graphic. I then expanded the post with a sober plea for buttons to generate italic, bold, and links with URL hidden behind an underlined word/phrase. The next day I got an e-mail from Robin, saying that somebody had posted spam using my ID and that I should change my Forums password. Maybe he was motivated by the fact that my Topic Title was "Whee! ...". ;) Anyway, my "Whee! ..." topic disappeared from this forum. :(


It turns out I have a web browser problem. I normally use Firefox (now version 42.0) on a Mac under OS X 10.10.5. When I post to the Retrospect Forums from it, clicking the More Reply Options button does not give me a toolbar with styling buttons above the text-entry pane.


Three days ago I tried posting from Safari, and there clicking the More Reply Options button does give me a toolbar with styling buttons above the text-entry pane. One thing that may be significant is that I currently have Adobe Flash selectively blocked on Firefox.


P.S.: When I Edit this post using Safari (it was originally composed on Firefox), I immediately get the toolbar with styling buttons etc. above the text-entry pane. When I click the Use Full Editor button—still in Safari, the toolbar goes away.

Share this post

Link to post
Share on other sites

I have now noticed a possibly-somewhat-related problem. Last night I tried signing in to this forum from my Mac Pro, using Firefox 41.0.2 under OS X 10.10.5. and I keep getting "Username or password incorrect". I get the same error message when I try to sign in from the Mac Pro using Safari 9.0.2.


Last night I even changed my password for the Retrospect forums from my MacBook Pro, just to make sure that it wasn't a question of the Mac Pro using an old password. I can still sign on from the MacBook Pro with the new password using either Firefox 42.0 or Safari 9.0.2—simultaneously. But the new password doesn't help when trying to sign in from the Mac Pro.


Here's a wild shot: Is membership on the Retrospect forums tied to a particular MAC address? Both my MacBook Pro and my Mac Pro have hard-coded 192.168.1 local URLs tied to their MAC addresses.


P.S.: Problem persists even after Firefox on Mac Pro updated to 43.0.3.


P.P.S.: In case it's not obvious, the reason I tried last night to sign into the Retrospect forums from my Mac Pro was to test whether the "styling buttons" problem reported in the OP for this thread is peculiar to the copy of Firefox installed on this MacBook Pro. I normally use the Mac Pro only as a Retrospect backup server.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this