Jump to content
infinitesunrise

Need to reboot file server mid-backup

Recommended Posts

Quick question:

 

I'm doing a very large (26TB) backup from an SMB file server to LTO6 tape. Incremental backup is turned off. The SMB server is an old, poorly-configured Linux box and transfer speed has crawled almost to a halt about halfway through execution. I know that rebooting the SMB server should get it working at speed again, but I don't know if this is possible to do mid-backup without losing everything I've done up to this point.

 

If I pause the execution, reboot the SMB server and then continue the execution once it comes back up, will it keep going from where it left off? Or will this sever the connection between Retrospect and the SMB server, destroying my progress?

 

Thanks. Any related tips also appreciated. :)

  • Like 2

Share this post


Link to post
Share on other sites

A couple of thoughts.

Transfer speed. How are you accessing the data on the SMB Server? Have you installed the new Linux Client which would be preferable and probably give better performance,  or just mounting a share on the Retro Server which will not perform nearly as well?

http://www.retrospect.com/en/support/kb/which-versions-of-linux-and-unix-does-the-client-support

 

Why disable Incremental Backup?  Retro is designed to do "Progressive" backups whereby it will backup everything it doesnt already have.

To create a full backup you need only start with an empty BackupSet (or recycle an existing one)

You can then run the backup as often as you like (rebooting the SMB in between) and Retro will effectively "Continue from where it left off"

Keep going till no new data is backed up - Check the Session Conttents in the Backup Set to see what is backed up on each run

The Snapshot will show you everything that was on the Client at the time of the backup

Share this post


Link to post
Share on other sites

I would have loved to install the Linux retro client on the SMB server, but when I said "poorly-configured Linux box", I really meant it. Its a 36-drive SuperMicro server similar to this one with an LSI MegaRAID card controlling 3 internal 14TB RAIDs. The operating system is Openfiler Linux (a now-defunct headless NAS OS controlled via web interface) running on a 1GB (!!!) partition, which joins the three 14TB RAIDs into a weird 44TB proprietary software SAN volume with an XFS filesystem. SAMBA can't even be configured correctly via the web gui for retrospect to connect to it, so I've had to manually create the correct configuration files via SSH to get it to connect at all. The Retrospect Client for Linux will absolutely not install because Openfiler Linux is an exotic "appliance" style OS that lacks or is incompatible with several libraries that the Retro client requires. I've tried, and determined that manually-configured SAMBA was the only way to go. I even tried booting the system with a Windows disk, but although Windows could see the 14TB volumes it couldn't re-construct the strange software SAN.

 

This system was created years ago by a predecessor, and I've been charged with getting all the data on it to LTO tape. It's a one-off operation, and after it's finished we'll be getting rid of the Linux sytem completely, good riddance. The fact that it's supposed to be a one-off is why incremental backup was disabled. We have a catalog of "job archives" that it's going to, most of which are backed up from a different location. Since this would be the only backup coming from this alternate source on the catalog, I figured I'd keep it simple by turning off incrementals. Probably would have helped me to leave it on though, yeah?

 

So basically I just need to know: If I pause the execution to reboot the file server, does it break my transfer even though it's paused?

 

Or, alternatatively: If I kill this backup right now at the halfway point, and restart a new one incrementally, will it recognize the stuff I've already backed up and skipped it, even though it wasn't backed up incrementally?

Share this post


Link to post
Share on other sites

Ah! OK

 

Just a thought, I guess the Raid Groups are handled by the LSI CVard, and presented to Open Filer as 3 Disks, Since Openfiler is built on linux it probably then uses  Logical Volume Manager to present the 3 raids as a single Logical Volume.

As you discovered Windows will not recognise this.

However you might get further, using an alternate Linux based system to boot.

If you haven't already come across "Parted Magic" you might give it a go. It's a linux based rescue disk with the linux GParted Partition utility and just about every other Open Source Disk & FIle utility you can think of.

I have had some success with it recognising MDADM & LVM objects, it has a bunch of copy / clone / image tools as well.

 

Back to Retrospect. I suspect that if you reboot the server it may indeed break the connection, but you might get lucky.

Retro DOES do File Level Single Instancing so it should skip stuff it already has.

 

If you just reenable the incremental on your backup config and leave it pointing to the same BackupSet it should preserve that existing data and continue to add missing stuff on each run. By the sound of it the data on the SMB is not changing, so keep going till nothing more gets backed up.

Share this post


Link to post
Share on other sites

Thank you! That's a ton of good advice, the pointer to Parted Magic in particular.

 

I'll go ahead and pause the backup and reboot the server. If that breaks the backup I'll restart it as an incremental and see if it recognizes what it's already backed up. If not, it'll be worth the time saved to see if Parted Magic can recognize the volume and put the Linux Retro Client on that instead.

 

edit - Success! The backup continued after server reboot, uninturrupted.

Share this post


Link to post
Share on other sites

I would stop the backup on the Retrospect server to save (gracefully) what is already backed up.

Reboot the Linux server.

Perform a "normal" backup. This will see the already backed up files as just that: Already backed up. So they will not be backed up again.

 

EDIT: I was typing while you posted.

Retrospect is quite forgiving against disconnect errors, so try pausing. At worst, Retrospect will stop the backup and you can start another backup.

 

A progressive ("incremental") backup is called a "normal" backup in Retrospect parlance.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×