Jump to content
Sign in to follow this  
Don Lee

"recycle" button grey!

Recommended Posts

I ran into a user error during a long sequence of scripts that had to run in the right order. One of the early media set copy operations failed, because the destination was too small (!! My Bad)

 

I wanted to pause everything, recycle the destiniation "manually", restart the copy, and then let the sequence proceed. Unfortunately, I was unable to recycle the destination media set because the "recycle" button was grey-ed out.

 

I looked at other options, but with all scripts paused, I could not do much without messing up my script sequence.

 

I noticed that the destination set that had failed the copy had *no* snapshots listed. I tried retrieving one of the snapshots, and it worked (without un-pausing everything, thankfully)

 

Once the snap retrieval was done, I could recycle the media set - re-run the failed copy, and re-enable the rest of the scripts.

 

I think this is a bug.  The "recycle" button should not depend on having a snapshot in the "backups" window. I should be able to recycle a media set that is hopelessly screwed up, or missing, or whatever. I think of it as the "big hammer", and I would expect retro to hammer the set back to the stone age immediately, possibly with a couple of whines if it would be unwise. (like if it would blow away files that look like they are not created by Retro, for instance)

 

As it is, the recycle button is slightly fragile. This is the only time I have had it grey, where I could force it to work. Mostly I have had to do something gross like delete the media set and re-create it. (re-adding to scripts, etc)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×