Jump to content
Sign in to follow this  
Don Lee

Can't change script without deleting and re-adding

Recommended Posts

I sometimes find that I can't change a script. In this case, I had a script that was set up to copy the latest backups from my "old" set to the cumulative "2015" set. The schedule is to do this once every three months for archive purposes.

 

The old script had the "2014" destination set, and all I wanted to do was change the destination to the "2015" set.

 

I would open the script, click the new destination, set the schedule, and hit "save". It would revert to the old destination set. I tried this a bunch of times. It turns out that the schedule is irrelevant. I click on the new destination, hit save, and the destination reverts back.

 

I tried stopping and re-starting both the console and the engine, and made sure nothing was running. I tried deleting and re-creating the destination media set (empty, as of today). The only thing I found that would allow me to change this script was to delete the script, and then re-add the script. THEN it would let me set the destination as I wished.

 

I smell a bug, although I don't know how to reproduce it. I've seen this before, but I can't pick out the pattern (yet!)

Share this post


Link to post
Share on other sites

One possibly relevant circumstance is that the original script being modified may have been active copying backups while I tried to change the destination - intended to apply only to _future_ runs of the script.

 

From what I've seen, it appears that Retro does not "run" a "copy" of a script, but runs the "original", and somehow locks it down to prevent problems with it changing while being run. This would explain a couple of my other reported bugs, and also this one.

 

But, I don't know. I'm only guessing.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×