Jump to content
TERRYRICKETTS

Grooming problem

Recommended Posts

We are running Retrospect 9.5.2.103 on two servers. For our workstations we presently have 21 backup sets. Each backup set is slightly over 1TB in size. They are all stored on a Dell PowerVault that is attached to the servers via scsi.

 

Several times a month we need to groom the backup sets to gain enough room for the next weeks backups. Generally about half of the grooming jobs will fail; all at the same spot. That spot is just after the data has been removed and the catalog file is about to be adjusted. A check of the backup set always shows the data to be fine, and the error message tells us we need to rebuild the catalog file.

 

In each case I will have the server rebuild the catalog file. Then to be sure everything is ok I will copy that backup set to a temporary store on a local NAS, and then copy it back. We never have a problem with rebuilding the catalog file, or the double copy. But the next time we groom about half of the jobs will fail again!

Share this post


Link to post
Share on other sites

Here are the appropriate errors from the logs for 5 of the grooms that ran last weekend:

 

        Grooming Backup Set Workstations H failed, error -2241 ( Catalog File invalid/damaged)
        You must recreate the Backup Set's Catalog File.
        See the Retrospect User's Guide or online help for details on recreating Catalog Files.
        Can't compress Catalog File for Backup Set Workstations H, error -1 ( unknown)
    11/15/2014 3:52:41 PM: 2 execution errors
        Duration: 02:20:58 (00:25:52 idle/loading/preparing)
    11/15/2014 3:52:41 PM: Script "Groom Workstations H" completed with 2 errors


        Grooming Backup Set Workstations E-F failed, error -2241 ( Catalog File invalid/damaged)
        You must recreate the Backup Set's Catalog File.
        See the Retrospect User's Guide or online help for details on recreating Catalog Files.
    11/14/2014 7:07:21 PM: Execution incomplete
        Duration: 02:37:29 (00:46:28 idle/loading/preparing)



        Grooming Backup Set Workstations W-Z failed, error -2241 ( Catalog File invalid/damaged)
        You must recreate the Backup Set's Catalog File.
        See the Retrospect User's Guide or online help for details on recreating Catalog Files.
    11/15/2014 3:13:48 PM: Execution incomplete


        Grooming Backup Set Workstations T-V failed, error -2241 ( Catalog File invalid/damaged)
        You must recreate the Backup Set's Catalog File.
        See the Retrospect User's Guide or online help for details on recreating Catalog Files.
    11/15/2014 3:48:20 PM: Execution incomplete
        Duration: 02:01:13 (00:37:52 idle/loading/preparing)



        Grooming Backup Set Workstations S2 failed, error -2241 ( Catalog File invalid/damaged)
        You must recreate the Backup Set's Catalog File.
        See the Retrospect User's Guide or online help for details on recreating Catalog Files.
    11/15/2014 2:28:12 PM: Execution incomplete
        Duration: 00:46:38 (00:22:04 idle/loading/preparing)

 

 

The catalog files were fine prior to the grooming, and there were no complaints while the data was being groomed. Somehow at the end when the catalog file itself needed to be cleaned up it had a problem.

Share this post


Link to post
Share on other sites

I have occasionally been hit by that problem since at least version 7.6. Now on 9.5 it is still there. I would have expected it to be fixed by now.

 

Anyway, all you can do is follow the instructions: "Recreate the Backup Set's catalog file". In version 7.6, that removed the backup set from all scripts where it was used. At least the scripts are now preserved in version 9.5

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×